Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Unmarshalling exception when uploading from Jenkins -> Dependency Track (version git: 4b4b0975bd7a9)

See original GitHub issue

Hi Steve,

  • I built the latest commit from git (4b4b0975bd7a9) and uploaded it to the server
  • Jenkins: dependency check plugin 3.2.1
  • I get an Exception in ScanUploadProcessingTask:
2018-06-07 17:40:54,221 [] ERROR [org.owasp.dependencytrack.tasks.ScanUploadProcessingTask] Error while processing scan result
2018-06-07 17:40:54,221 [] ERROR [org.owasp.dependencytrack.tasks.ScanUploadProcessingTask] javax.xml.bind.UnmarshalException
 - with linked exception:
[ ParseError at [row,col]:[1,1]
Message: Premature end of file.]
  • To check if the XML report itself is OK, I uploaded it via curl manually, it worked.

I can provide the report XML tomorrow if you need it - would need to clean up confidential information first. Let me know if you are interested.

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:5 (4 by maintainers)

github_iconTop GitHub Comments

MichaelGissingNCcommented, Jun 8, 2018

Thanks for the help Steve, I figured it out, although the hint to the cause was already in the original message. In contrast to the DependencyCheckPublisher, the DependencyTrackPublisher doesn’t have a default value for artifact and returns success in this case.

I’ll close this issue and open an issue with jenkinsci/dependency-check-plugin

lock[bot]commented, Sep 27, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed. Please open a new issue for related bugs.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Better Error Handling for Scan Upload · Issue #162 ... - GitHub
I just tried to manually upload a dependency check XML. ... Unmarshalling exception when uploading from Jenkins -> Dependency Track (version git: ...
Read more >
OWASP Dependency-Track - Jenkins Plugins
Asynchronous publishing simply uploads the SBOM to Dependency-Track and the job continues. Synchronous publishing waits for Dependency-Track ...
Read more >
OWASP Dependency Tracker - Jenkins build error
I was able to resolve the issue by assigning VULNERABILITY_ANALYSIS permission to the token used by Jenkins. Tokens and their permissions ...
Read more >
[JIRA] (JENKINS-51053) Fail to publish Dependency-Track ...
[DependencyTrack] Publishing artifact to Dependency-Track ERROR: Build step failed with exception java.lang.NullPointerException
Read more >
Community Integrations - Dependency-Track
Since Dependency-Track follows the API-First approach of product development, the API itself provides vast possibilities to make custom tools and ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found