Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Cannot find name 'useAsyncGql'.ts in stable release

See original GitHub issue


  • Operating System: Darwin
  • Node Version: v14.18.3
  • Nuxt Version: 3.0.0-rc.14
  • Nitro Version: 1.0.0
  • Package Manager: npm@9.1.1
  • Builder: vite
  • User Config: vite, modules, runtimeConfig, build, app
  • Runtime Modules: nuxt-graphql-client@0.2.10
  • Build Modules: -

Describe the bug

I have just upgraded nuxt to latest stable release, and I get the following error:

Cannot find name 'useAsyncGql'.

Is it a known issue or something?

Expected behaviour

Being able to use useAsyncGql in vue files.


No response

Additional context

No response


No response

Issue Analytics

  • State:closed
  • Created 10 months ago
  • Comments:5 (3 by maintainers)

github_iconTop GitHub Comments

pzpsofficialcommented, Nov 16, 2022

@Diizzayy Oooh, so that’s what makes a great developer great 😄 Thank you so much, it’s working like a charm. Thanks again, and all best!

Diizzayycommented, Nov 16, 2022

@pzpsofficial Happy to help!

Read more comments on GitHub >

github_iconTop Results From Across the Web

[typescript-react-apollo] TS Error "Cannot find name ... - GitHub
When I ran graphql-codegen with the following schema.json, the typescript-react-apollo plugin generates incomplete TypeScript source, saying " ...
Read more >
ts Cannot find name 'async' via TypeScript - Stack Overflow
Solved With This: var test = async() => { let asyncFn = () => { return new Promise((resolve: Function) => { resolve(2); });...
Read more >
Why do I get "Cannot find name" errors in a TypeScript script ...
In line no. 2: import { Pool } from "@uniswap/v3-sdk";. Include the missing module: import { Pool, nearestUsableTick } from "@uniswap/ ...
Read more >
Minimal GraphQL Client + Code Generation for Nuxt - JsRepos
Can be omitted, * module will automatically search for GraphQL ... Not really sure whats going on here as I can't find anything...
Read more >
Minimal GraphQL Client + Code Generation for Nuxt3
I got the same error in local with the exact same setup. opened by colinscz 14. Missing server build import files: Cannot find...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found