Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Bugs regarding 1.14 (master and 1.14-in-dev)

See original GitHub issue

Currently running the old (before we really got involved) mod (2.6.0) against our newest 1.14-in-dev branch. This is a list of issues / bugs that I’d like to have resolved before release.

3.0.5 (+ in-dev):

  • Connected surface will not validate if a block is within a wall or not. Needs to be able to do so. Either all the time or on by default.
  • Whilst the builder will validate if a block can be placed in the specific location, the exchanger fails to do so. This means you can take the top half of a plant for example (Only valid placement is on top of the same plant) and place it on the ground.
  • Exchanger shouldn’t be able to place torches as it allows for instant mining of blocks when the auto-placement of the torch is on an in-valid location.
  • Stop torches popping off their block when having the block exchanged (Fixed by ignoring torches for the exchanger)
  • Charging station doesn’t switch texture when active
  • Charging station needs a burn icon or something to show it takes burnables
  • Charging station needs the energy number to be under the word Energy and to have it comma formatted 👍
  • Construction Blocks no longer simulate the hardness of the other blocfk and have shovels as their tool class
  • You can select a construction block (after being placed by the gadget) and it’ll render a standard construction block. The old versions select the current construction block but with the block data that it’s pretending to be so you can place more of them. If this is a 1.14 issue then just disable selecting it with a messaging telling you a construction block and not a normal block
  • Builds available blocks in the order in which they appear, not sorted closest to furthest: (compared to 1.12
  • You can build when the selection is inside of you allowing you to kill yourself (this is a result of making effect Blocks TileEntities - previously when they were Entities, they pushed you out)
  • Charging station do not show black overlay when in their GUI’s.
  • Template Manager and Charging station do not support JEI. Todo: found out why.
  • Charging station should keep it’s charge when broken
  • Exchanger shouldn’t replace blocks which aren’t visible to the player. We need to be careful to support the edge case of half blocks etc which would make the face partial visible.
  • Replace Destruction gadget gui completely and make it more user friendly and move it off of shift right click. Currently I’m thinking about rendering a 3d outline that the player can move their mouse over and drag to increase and decrease the vector they wish to change. This would also auto cap meaning players don’t need to do math in their head for it haha.
  • Remove all gadgets shift right-click functionality and push it all onto a button on the main g menu.


  • Tool Mode status text missing space between “prefix:suffix” should be “prefix: suffix”
  • This weird undo behaviour not sure what is causing that but it’s not like how it should be. It would seem the tile / render doesn’t know what it should be for a while… On reflection, I think it’s because of the new enum on the Tile. It first renders a blank redness then pauses and renders the block properly.
  • Copy and paste text on the modes is in all caps? Seems angry, should calm it down a bit.
  • message.gadget.areareset doesn’t exist for Copy area clearing
  • Gadgets all: Energy should always be in the same place on the tool tip. Current Building and Copy paste is on different lines to the rest. Should either be at the very top or at the very bottom. (possibly also 3.0.5)
  • Crash on undo when using construction paste: (Cannot reproduce, I added code, that will prevent this crash, but it should not have happened in the first place as it indicates that one tried to insert an ItemStack of Items.AIR)
  • Console spam on start up regarding item-serializer (Fixed with new Worlds)
  • Blocks show as unbuild-able even when you have a full construction paste container: (I fail to reproduce this, I calculated how much paste I needed for these blocks and always to the same result… If you could send me the paste that makes Problems, I’ll try again)
  • Missing slot images? likely the old template manager code: (Cannot be reproduced, try cleaning your caches+re-running genIntellijRuns and then doing a full build)
  • Undo doesn’t put torches back in the inventory. (Cannot reproduce)
  • Missing i18n on size failure on destruction gadget
  • This is a really old bug… When shift right-click you can bypass area size checks by setting an area without already having an area selected. This shouldn’t happen. Although the cords mode is logically useful, I think we should disable it / add clearer text to show if you’re in cords mode or not and if you’re not then the inputs should be disabled. We should also fix the size check bypass(different for in-dev)
  • Copy mode has no clear way of showing if the first selection was successful. Can we either show a highlight around the first block or just build that block as the first and last block so the render shows? or just something in status to say “Pos 1 set”

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:6 (3 by maintainers)

github_iconTop GitHub Comments

MichaelHillcoxcommented, Oct 21, 2019

If it’s solved please add a commit id next to the issue and check it off 😄

MajorTuvokcommented, Oct 21, 2019

I don’t know when that happened, sorry. I tested it know, and can reproduce it only with a world which contains things from previous world saves. I’ll just add the last commit that touched it.

Read more comments on GitHub >

github_iconTop Results From Across the Web

No cables connect to Storage Network Manager (v1.14.4- ...
I think its a visual only issue, they connect in the network but not in graphics. And sometimes in 1.14 you have to...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found