Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Partials not found error

See original GitHub issue

Hi there,

I’ve only found one submission for this problem but the fix doesn’t work for me. Every so often at random intervals I get the error: file to import not found or unreadable: partials/header

I’ve tried setting the include paths but to no avail. My task looks like:

gulp.task('sass', function() {
        .pipe(sass({style: 'expanded', includePaths: [ './assets/scss/partials', './assets/scss/modules', './assets/scss/helpers' ], errLogToConsole: true }))
        .pipe(autoprefixer('last 2 version'))
    .pipe(rename( + '.css'))
        // .pipe(reload({stream: true}))
        //.pipe(notify({message: 'SCSS processed!'}));

I also tried commenting parts out in order to find a problem line but nothing seems to help. Any ideas?

Issue Analytics

  • State:closed
  • Created 8 years ago
  • Comments:79

github_iconTop GitHub Comments

kylevacommented, May 7, 2015

@smiddus +1 – In Sublime Text 3, after setting the atomic_save property to true in my user settings I no longer receive this error.

smidduscommented, May 7, 2015

Hey guys, I don’t know if it helps, but I just found out that enabling atomic save in Sublime Text 3 fixes the problem for me ( I had set it to false, default is true).

Read more comments on GitHub >

github_iconTop Results From Across the Web

How to Solve The partial head could not be found Handlebars
You need to register the path to partials directory while configuring express-handlebars and move your partials to that folder.
Read more >
Partials not found · Issue #151 · pillarjs/hbs - GitHub
Hi. Im trying to include hbs partials on my main.hbs but im getting an error that partials could not be found.
Read more >
How to fix Hugo's 'partial not found' error message? -
The 'partial not found' error message happens when Hugo cannot find a partial that we reference in a theme template file (GitHub, 2017)....
Read more >
New partials not working in handlebars example - Glitch Support
Hi, I am trying to use a remix of the handlebars template example which works fine until I create new partials and include...
Read more >
Partials | Handlebars
The normal behavior when attempting to render a partial that is not found is for the implementation to throw an error.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found