Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

App not building after installing ember-service-worker

See original GitHub issue

After running ember install ember-service-worker, my app fails to build. I’m not really getting much in terms of console output, but this is what I see:

Could not start watchman
Visit for more info.
DEPRECATION: Addon files were detected in `/Users/caseyjenks/sites/fitbot-client/node_modules/ember-inject-script/addon`, but no JavaScript preprocessors were found for `ember-inject-script`. Please make sure to add a preprocessor (most likely `ember-cli-babel`) to in `dependencies` (NOT `devDependencies`) in `ember-inject-script`'s `package.json`.
Warning: failed to stat /Users/caseyjenks/sites/fitbot-client/tmp/autoprefixer_filter-tmp_dest_dir-2PQnDGhJ.tmp/assets/failed.png

The deprecation warning shows up in master branch of the project, but the Warning: failed to stat... is new.

Any ideas?

Version: 0.6.12

Issue Analytics

  • State:open
  • Created 5 years ago
  • Reactions:1
  • Comments:6 (1 by maintainers)

github_iconTop GitHub Comments

pvertentencommented, Apr 11, 2018

So I solved the issue I believe. Thought I don’t have a long term solution. Maybe report the issue to ember-rails, or see what ember-service-worker is doing with the tmp directory.

The issue seems to be that ember-rails seems to leave a lot of extra things behind in the tmp directory, and this only grows over time while developing the app. I had a few GB of left over data in the tmp directory from previous runs.

… asset_map-cache_path-hsRQ5VAH.tmp broccoli_merge_trees-cache_path-6LVndSRy.tmp broccoli_merge_trees-cache_path-6mz1PwG4.tmp …

With all this left behind stuff and ember-service-worker the build seems to take very long. Not sure what the build is doing, but clearing out the tmp directory before building speeds everything up to basically normal build speed.

koushik-radhakrishancommented, May 11, 2022

I don’t use ember-CLI-rails but still this is happening. How you guys solved this? Any working solution?

Read more comments on GitHub >

github_iconTop Results From Across the Web

Setup of ember-service-worker-cache-fallback to sync data
When I'm offline the app works, but network requests are not executed once I go back online. All network requests are actually executed...
Read more >
How to build a Progressive Web App with Ember - DockYard
This tutorial will go through the basics of making your Ember app home screen installable and available offline.
Read more >
ember-service-worker-index - npm
An Ember Service Worker plugin that caches the index.html file. Latest version: 0.7.2, last published: a year ago.
Read more >
Building a Progressive Web App with Ember ::
Contains some content when JavaScript not available. Redirects HTTP traffic to HTTPS. User can be prompted to Install the Web App.
Read more >
Fix an installed Android app that isn't working - Google Support
Try the following steps if an app installed on your phone has any of these problems: Crashing. Won't open. Won't respond. Isn't working...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found