Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Google unable to boot after weresync completes.

See original GitHub issue

Hey there, I’m not able to get Google VM to boot after completing the sync from a 1TB to 200GB disk. There’s plenty of room (only using about 45GB), but there are some odd messages that popup when I’m completing the migration.

Creating new GPT entries. The operation has completed successfully. Checking partition validity. weresync.interface - Partition count on two drives different. Invalid. Partitions invalid! Copying drive partition table. weresync.interface - Drives are incompatible. The operation has completed successfully. weresync.device - Invalid filesystem type found. Partition 14 not formatted. Beginning to copy files. weresync.device - Error copying data for partition 14 from device /dev/sda to /dev/sdb. Copying partition 15 Copying partition 1

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:10 (2 by maintainers)

github_iconTop GitHub Comments

1upkdcommented, Oct 29, 2021

Was stuck with the issue and this helped. Thanks @ClarinetK622

This is an old post, but I tried to follow the solution here and had no luck. For those who are still running into problems, here is an alternative solution.

I was able to resolve my issues booting a weresync shrunken drive in GCE by creating the new smaller drive from a public bootable image (Ubuntu 18.04 LTS: ubuntu-1804-bionic-v20210504). This marks the the drive as UEFI compatible, whereas when I started with a blank drive it would not let me set it as a boot disk on my UEFI instance. It also created a partition 14 on the new drive by default which weresync always failed to copy over from the old one (not sure how important this is). I then mounted the drive onto my VM and cloned my source boot drive to it using weresync with the following command. Notice my source drive has an EFI partition, which also may have been the cause of my problems when following the above solutions.

sudo weresync -C -L grub2 -E 15 -g 1 /dev/sda /dev/sdc

I then stopped the server, replaced the large boot drive with the smaller one, and it booted right up. I had to reconfigure my fstab to get my secondary drive to mount properly, but that’s it. Hopefully this helps someone stuck in my position where seemingly no solutions worked!

ClarinetK622commented, Oct 29, 2021

@1upkd Happy to be of service! This is an annoying problem to run into, for sure.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Error: Reducing the Size of a Persistent Disk - Google Groups
After the command completes, create a new VM in GCE, specifying the new disk as your boot disk. Ideally, the new VM should...
Read more >
Google Cloud How to reduce disk size? - Stack Overflow
Start a new instance with this disk as the new boot disk. I was successful in cloning a disk via this method, but...
Read more >
Google Cloud How to reduce disk size? - Stack Overflow
I have an SDD disk of 200GB in Google Cloud, that I want to reduce to 50GB. ... Install weresync via a .deb...
Read more >
WereSync Documentation - Read the Docs
WereSync cannot properly install all bootloaders. You may have to manually adjust some settings after the clone finishes.
Read more >
How to modify a VM instance setting to boot from BIOS to UEFI
I shrank my boot hard disk size on my Google Cloud Compute VM. ... onto my VM and cloned my source boot drive...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found