Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Fedora 32: No SDKs were found

See original GitHub issue

Hello! I followed the instructions here:

For installing dotnet core SDK and runtime using the Fedora package manager, using the commands:

sudo dnf install dotnet-sdk-3.1
sudo dnf install aspnetcore-runtime-3.1
sudo dnf install dotnet-runtime-3.1

Note that the 2nd and 3rd command above did nothing, because the first command for the sdk installed everything.

After successfully installing, I can see that I have all the packages:

$ sudo dnf list installed 'dotnet*'
Installed Packages
dotnet-apphost-pack-3.1.x86_64                              3.1.3-1.fc32                             @updates                    
dotnet-host.x86_64                                          3.1.3-1.fc32                             @updates                    
dotnet-hostfxr-3.1.x86_64                                   3.1.3-1.fc32                             @updates                    
dotnet-runtime-3.1.x86_64                                   3.1.3-1.fc32                             @updates                    
dotnet-sdk-3.1.x86_64                                       3.1.201-1                                @packages-microsoft-com-prod
dotnet-targeting-pack-3.1.x86_64                            3.1.3-1.fc32                             @updates                    

The problem is, however, that no SDK’s are detected

$ dotnet --info
  It was not possible to find any installed .NET Core SDKs
  Did you mean to run .NET Core SDK commands? Install a .NET Core SDK from:

Host (useful for support):
  Version: 3.1.3
  Commit:  4a9f85e9f8

.NET Core SDKs installed:
  No SDKs were found.

.NET Core runtimes installed:
  Microsoft.AspNetCore.App 3.1.3 [/usr/lib64/dotnet/shared/Microsoft.AspNetCore.App]
  Microsoft.NETCore.App 3.1.3 [/usr/lib64/dotnet/shared/Microsoft.NETCore.App]

To install additional .NET Core runtimes or SDKs:

System info

$ cat /etc/*release
Fedora release 32 (Thirty Two)
VERSION="32 (Workstation Edition)"
PRETTY_NAME="Fedora 32 (Workstation Edition)"
VARIANT="Workstation Edition"
Fedora release 32 (Thirty Two)
Fedora release 32 (Thirty Two)

If I check my path for my non-root user, the only dotnet related entry is /home/wes/.dotnet/tools.

I’ve tried uninstalling and reinstalling this half a dozen times and I can’t get it to recognize or detect the SDK. What can I do to get this working?

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:12 (2 by maintainers)

github_iconTop GitHub Comments

wes-novackcommented, May 2, 2020

I resolved this issue by running: sudo dnf remove dotnet-sdk-3.1

And then following most of the instructions here:

sudo rm -rf /usr/share/dotnet
sudo rm -rf /usr/bin/dotnet
sudo rm -rf /etc/yum.repos.d/microsoft-prod.repo
sudo dnf clean all
sudo dnf upgrade
sudo init 6 #reboots the machine

Then sudo dnf install dotnet-sdk-3.1

I did not use the wget or rpm commands suggested in the stackoverflow post, as they aren’t necessary in Fedora 32 because dotnet appears to be included in the OS repos now.

The commentary on that post suggests that the sudo dnf clean all might have been the thing that solves the problem.

RedCloudSolutionscommented, Aug 10, 2021

The issue is likely due to the differences in the Fedora repos vs. the Microsoft repos. Microsoft’s repo installs the runtime into /usr/share/dotnet, which is where the CLI will look if it comes from a Microsoft-installed package. Fedora installs dotnet-* to /usr/lib64/dotnet and looks for the installed SDKs and runtimes there instead.

Try this to fix your issue (worked for me with Fedora 34):

  1. Remove anything your have installed for .NET: $ sudo dnf remove dotnet-*
  2. Re-install by disabling the Fedora repos and enabling Microsoft’s: $ sudo dnf install --enablerepo=packages-microsoft-com-prod --disablerepo=updates --disablerepo=fedora dotnet-sdk-5.0

After I did this, the SDK was found: $ dotnet --info .NET SDK (reflecting any global.json): Version: 5.0.302 Commit: c005824e35

Runtime Environment: OS Name: fedora OS Version: 33 OS Platform: Linux RID: fedora.33-x64 Base Path: /usr/share/dotnet/sdk/5.0.302/

Host (useful for support): Version: 5.0.8 Commit: 35964c9215

.NET SDKs installed: 5.0.302 [/usr/share/dotnet/sdk]

.NET runtimes installed: Microsoft.AspNetCore.App 5.0.8 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App] Microsoft.NETCore.App 5.0.8 [/usr/share/dotnet/shared/Microsoft.NETCore.App]

To install additional .NET runtimes or SDKs:

Read more comments on GitHub >

github_iconTop Results From Across the Web

Dotnet SDK not foun, but it's installed : r/Fedora
Hi there, after update to Fedora 32, dotnet can be found in official Fedora's repos. ... NET Core SDKs installed: No SDKs were...
Read more >
NET Core 3.1 installed on Fedora 32 but it doesn't work
When I switch to that directory. Don't run dotnet new from within the /usr/bin directory. What's in there is a symlink to the...
Read more >
Fedora 36 dotnet 6 installation
I read this issue Fedora 32: No SDKs were found · Issue #11533 · dotnet/sdk · GitHub and did everything, but it is...
Read more >
Install the .NET SDK or the .NET Runtime on Fedora
Demonstrates the various ways to install .NET SDK and .NET Runtime on Fedora.
Read more >
NET SDK wouldn't show up on Fedora 36
Reinstalled successfully, still won't show up. Even tried. sudo dnf install dotnet-sdk-6.0.x86_64. No result after installation. dotnet --info.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found