Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Running `dotnet restore` hangs

See original GitHub issue

Steps to reproduce

dotnet new dotnet restore

Expected behavior

Packages are downloaded

Actual behavior

Hangs at first output line Restoring packages for ....

Environment data

dotnet --info output: `.NET Command Line Tools (1.0.0-rc2-002586)

Product Information: Version: 1.0.0-rc2-002586 Commit Sha: ac5432bff2

Runtime Environment: OS Name: rhel OS Version: 7.2 OS Platform: Linux RID: rhel.7.2-x64`

Note: This is RHEL running in a Hyper-V VM on Windows 10 Professiona.

Issue Analytics

  • State:closed
  • Created 7 years ago
  • Comments:7 (1 by maintainers)

github_iconTop GitHub Comments

stanislavromanovcommented, Oct 4, 2016

rm -rf /tmp/NuGet rm -rf /tmp/NuGetSearch

If this does not help reboot the system.

default-writercommented, Dec 9, 2018

reboot the system.

problem is that you have max-out to you limit for open handles fordotnet process (build, kesterl, nginx, etc)

Read more comments on GitHub >

github_iconTop Results From Across the Web

dotnet restore hangs indefinitely · Issue #724
I looked that while having many libs in the folder wwwroot\lib dotnet restore takes a while to restore the files, If I remove...
Read more >
`dotnet build` and `dotnet restore` hangs forever without ...
I tried to run dotnet build and dotnet restore . It hangs forever without any error. Screenshot: dotnet restore hangs forever without any ......
Read more >
[SOLVED] dotnet restore stuck when building project ...
i was trying to build a project using dotnet, but the commands "dotnet run" "dotnet build" and "dotnet restore" always got stuck giving...
Read more >
Dotnet restore never completes on M1 Mac when targeting ...
When I try to build for amd64 the build gets hung up on the dotnet restore command. I have tried building using both...
Read more >
Docker in .NET 6 Stuck on "RUN dotnet restore --no-cache"
Docker in .NET 6 Stuck on "RUN dotnet restore --no-cache". I'm trying to build an image in .NET 6 but is stuck and...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found