Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Support for libicu 57 (default for Fedora 25)

See original GitHub issue

Steps to reproduce

On Fedora 25, install dotnet following instructions for Fedora 24

Expected behavior

dotnet --version works

Actual behavior

dotnet --version returns Failed to initialize CoreCLR, HRESULT: 0x80131500, typical of wrong libicu, as reported in and others

Issue Analytics

  • State:closed
  • Created 7 years ago
  • Reactions:8
  • Comments:9 (3 by maintainers)

github_iconTop GitHub Comments

victorperincommented, Jul 5, 2017

Can someone reopen this issue? It still happening, we don’t have libicu 57 support.

ghostcommented, Jun 30, 2017

Hi everyone, I found temporary workaround:

  1. Prerequisites. Please install lldb too. sudo dnf install libunwind libicu sudo dnf install lldb

  2. Get libicu-56 for Fedora 24 wget

  3. Extract the rpm contents. rpm2cpio libicu-56.1-4.fc24.x86_64.rpm | cpio -idmv

  4. Move the required files sudo cp -v ./usr/lib64/* /usr/lib64 && rm -Rvf ./usr

After that dotnet should work as expected.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Support for libicu 57 (default for Fedora 25) · Issue #7269
On Fedora 25, issue #5455 is still relevant. I've tried some workarounds similar to the ones that worked for Fedora 24 (using different...
Read more >
Firefox starts in private browsing mode - Ask Fedora
Hi, I am not sure whether to ask here or at firefox support first, anyway I start here. Description of the problem is...
Read more >
Fedora 25 : icu (2016-81613d042d)- vulnerability database |...
fedora. unix. [SECURITY] Fedora 25 Update: icu-57.1-2.fc25 ... which allows remote attackers to cause a denial of service (out-of-bounds read) or possibly ...
Read more >
Fedora 37's default beta wallpaper!
Fedora 37 has branched off from Rawhide and this is its default wallpaper. Here's a link to the designer's blog!
Read more >
Couldn't find a valid ICU package when using Container ...
Part of my release process is attempting to run a Bash script against a custom Container Image (set as the Container Image property...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found