Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

[BUG]: JAVA_HOME is not set.

See original GitHub issue

Describe the bug A problem occurred configuring root project ‘MVVMTemplate’.

=============================== Gradle Doctor Prescriptions ============================================ | JAVA_HOME is not set. | | Please set JAVA_HOME so that switching between Android Studio and the terminal does not trigger a fu | | ll rebuild. | | To set JAVA_HOME: (using bash) | | echo “export JAVA_HOME=$(/usr/libexec/java_home)” >> ~/.bash_profile | | or ~/.zshrc if using zsh. | | | ========================================================================================================

To Reproduce Steps to reproduce the behaviour:

  1. Open this project template in macos.

Expected behaviour A clear and concise description of what you expected to happen.

Screenshots If applicable, add screenshots to help explain your problem.

Smartphone (please complete the following information):

  • Device: [e.g. Pixel 3]
  • OS: [e.g. Android10]
  • Version [e.g. 30]

Additional context Add any other context about the problem here.

Issue Analytics

  • State:closed
  • Created a year ago
  • Comments:5 (2 by maintainers)

github_iconTop GitHub Comments

Drjackycommented, Jun 18, 2022

You can disable the “failed on java home is not set” attribute here:

Drjackycommented, Jun 16, 2022

This happens since AS Chipmunk 2021.2.1 Patch 1 update. There is a solution for that Although, I’m not sure how to follow it! If you found the solution, would be great to share it with the rest of us

Read more comments on GitHub >

github_iconTop Results From Across the Web

Hadoop: «ERROR : JAVA_HOME is not set» - Stack Overflow
In the current version 2.9.0 it is present but takes the current environment's JAVA_HOME forward. The doco there suggests that this value should...
Read more >
Solved: Error: JAVA_HOME is not set and could not be found...
Solved: I am trying to run HDP inside a Ubuntu 14.04 docker image. HDP 2.3.2 was installed using the official - 99061.
Read more >
Visual studio code error JAVA_Home is not set and ... - YouTube
windows 11:important: if after you follow this video the problem is still not solved, please double check if you install the correct version ......
Read more >
ERROR: JAVA_HOME is not set and no 'java' #85925 - GitHub
Steps to Reproduce ... try running an android emulator for the first time ... ... Logs Logs ```Please set the JAVA_HOME variable in...
Read more >
Getting OPatch Error 'JAVA_HOME Is Not Set Or Does Not ...
Oracle Fusion Middleware - Version and later: Getting OPatch Error 'JAVA_HOME Is Not Set Or Does Not Exist' When Applying Patch ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found