Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

SPConfigWizard | launch Get-SPProduct -local to refresh the Config Database

See original GitHub issue

patch status

Details of the scenario you tried and the problem that is occurring

When Patchin the farm with SPConfigWizard, one of my server is giving “Missing Required” int the Manage Patch Status. I had to manually launch the command “Get-SPProduct -local” to refresh the configuration cache.

Suggested solution to the issue

In the Set-TargetResource, Before launching the configuration Wizard, launch Get-SPProduct -local

The operating system the target node is running

OsName : Microsoft Windows Server 2016 Datacenter OsOperatingSystemSKU : DatacenterServerEdition OsArchitecture : 64-bit WindowsBuildLabEx : 14393.3659.amd64fre.rs1_release_1.200410-1813 OsLanguage : en-US OsMuiLanguages : {en-US}

Version of SharePoint that is used (e.g. SharePoint 2016)

SharePoint 2013 SP1 + CU March 2019

Version and build of PowerShell the target node is running

PSVersion 5.1.14409.1018 PSEdition Desktop PSCompatibleVersions {1.0, 2.0, 3.0, 4.0…} BuildVersion 10.0.14409.1018 CLRVersion 4.0.30319.42000 WSManStackVersion 3.0 PSRemotingProtocolVersion 2.3 SerializationVersion

Version of the DSC module that was used


Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:6 (4 by maintainers)

github_iconTop GitHub Comments

Phentrincommented, Jul 31, 2020

It worked with the command Thanks Yorick.

ykuijscommented, Oct 27, 2020

Will be included in my next Bugfix PR

Read more comments on GitHub >

github_iconTop Results From Across the Web

After patching while running product config wizard is failing
According to the information in the log, the problem should be that the operating account does not have the permission of the database....
Read more >
SharePoint 2013
I tested a 4 server SharePoint 2013 farm and ran the entire process in just 45 minutes. Stopping services and dismounting content databases...
Read more >
It Appears once, On page refresh everything works fine - ...
To connect this server to the server farm, use the SharePoint Products Configuration Wizard, located on the Start menu in Microsoft SharePoint ...
Read more >
This will refresh the Configuration database with the installed products. ... SharePoint Diary SPConfigWizard launch Get-SPProduct -local to refresh …
Read more >
I had to manually launch the command "Get-SPProduct -local" to refresh the ... is here: SharePoint Configuration Wizard updates the database schema to...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found