Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Missing method exception: Value binary comparison (but should be propery)

See original GitHub issue

Hi, We want to stay up to date with the changes in V3, this means we need to rewrite all our current db functions to use LinqBuilders, but we have run into a hurdle and I am unsure why it is happening.

Given :

    open Dapper.FSharp.MSSQL
    open Dapper.FSharp.LinqBuilders

    let companyTable = table'<ReadRecord> "Company" |> inSchema "Common"

    let getRecordByGuidV2AO (connection : SqlConnection, transaction) guid =

      let selectQuery = select { for i in companyTable do
                                 where (isIn i.CompanyGuid [guid])}
      connection.SelectAsync<ReadRecord> (selectQuery, transaction)
      |> Async.AwaitTask
      |> (Seq.tryHead >> ReadRecord.toDomainX)

    let getRecordByGuidAO (connection : SqlConnection, transaction) guid =

      let selectQuery = select { for i in companyTable do
                                 where (i.CompanyGuid = guid )}
      connection.SelectAsync<ReadRecord> (selectQuery, transaction)
      |> Async.AwaitTask
      |> (Seq.tryHead >> ReadRecord.toDomainX)

The function getRecordByGuidV2AO works and tests successfully, however, the function getRecordByGuidAO gives expection which relates to this match. I can see the test works : simple select, the only difference being that we are passing the comparison value as a parameter to the function. I must be missing something silly, but cannot see it.

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:9 (9 by maintainers)

github_iconTop GitHub Comments

TerenceHinrichsencommented, Oct 19, 2021

I truly do not understand what happened, but I recloned the repo, redid the tests and all seems to be operating again. Thank you so much @JordanMarr for your help in trying to find the issue!

JordanMarrcommented, Oct 12, 2021

Not necessarily… it just seemed odd. I tried reverting to pre v3 and I still can’t reproduce it.

Read more comments on GitHub >

github_iconTop Results From Across the Web

System.MissingMethodException after adding an optional ...
I am getting error of System. MissingMethodException after I have an optional parameter in one component and the other component which call it ......
Read more >
MissingMethodException / "Method not found" after update ...
Hi, Today I've tried updating the NuGet package from to and I'm running into an issue with a specific test case...
Read more >
MissingMethodException Class (System)
Gets the text string showing the class name, the method name, and the signature of the missing method. This property is read-only. Source....
Read more >
System.MissingMethodException Class
MissingMethodException.Message property of the new instance to a system-supplied message that describes the error, such as "Attempted to access a missing method ...
Read more >
I'm integrating the addressables system in my project. In the editor all works fine, but when I build from iOS and I try...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found