Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Good morning,

Not an issue (I think) but just a note that if like myself if you already have a custom language defined (mine was TypeScript) then npm package fails. Only way to install it to get source and then go to

Language -> User Defined Language -> Define your language...

Then import the udl of your choice. Then it works and shows your chosen md themed language.


Kind Regards.

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Reactions:1
  • Comments:6 (3 by maintainers)

github_iconTop GitHub Comments

fwd079commented, Feb 18, 2021

Great. Solved, I guess. 🙂

As said it is mainly NP++'s problem. But thanks for looking into it. The workaround works, closing it now.

Kind Regards.

Edditoriacommented, Feb 18, 2021

I have tried to reproduce the problem. Yes, it seems that it is the problem of “cloud” function in NPP.


When “Cloud” directory is set in NPP’s Preferences, the <userDefineLangs\> folder is not created automatically.

NPP will not open the folder when you click in menu: Language → User Defined Language → Open User Defined Language folder…


I still prefer to use the <userDefineLangs\> to manage your UDL files, rather than modifying a single UDL in the old days.

Let say: You setup your cloud directory at <%UserProfile%\Documents\Notepad++\>

  • Manually create a folder called “userDefineLangs” in your cloud folder.
  • Copy or move all UDL files into the folder.
  • Restart NPP.

If it is setup correctly, NPP will open Explorer when you click in menu: Language → User Defined Language → Open User Defined Language folder…

Run npx markdown-plus-plus command in your new <userDefineLangs\>, instead of the default one.


Read more comments on GitHub >

github_iconTop Results From Across the Web

Common errors | npm Docs
It's most likely a temporary npm registry glitch. Check npm server status and try again later. If the error persists, perhaps the published...
Read more >
npm install error from the terminal - Stack Overflow
If npm runs at all, it means node is already installed. npm install is for installing packages. – loganfsmyth. Mar 17, 2014 at...
Read more >
5 Ways to Fix the Npm Install Not Working Issue
Way 1. Make Sure Npm Is Installed. The main cause of the npm command not found error is that npm is not installed....
Read more >
NPM install error - Material Design for Bootstrap
Trying to install MDB pro 4.19.2 just downloaded and ran npm install but getting this error of sha512 not matching. Can someone tell...
Read more >
cannot find module [Node npm Error Solved] - freeCodeCamp
How to Fix the "cannot find module" Error · delete the node modules folder by running rm -rf node_modules · delete package.lock.json file...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found