Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

`embark blockchain` crashes on a new installation (Cannot read property '1' of null)

See original GitHub issue

OS: Win10 Embark version: 2.4.2

Just installed embark and ran embark blockchain


Embark Blockchain Using: Go-Ethereum (
running: geth --networkid 12301 --datadir=".embark/development/datadir" --password config/development/password account list
WARN [05-24|13:54:45] No etherbase set and no accounts found as default
already initialized
    address = result.output.match(/{(\w+)}/)[1];

TypeError: Cannot read property '1' of null
    at Blockchain.initChainAndGetAddress (C:\Users\User\AppData\Roaming\nvm\v7.5.0\node_modules\embark\lib\cmds\blockchain\blockchain.js:79:45)
    at (C:\Users\User\AppData\Roaming\nvm\v7.5.0\node_modules\embark\lib\cmds\blockchain\blockchain.js:50:22)
    at Object.blockchain (C:\Users\User\AppData\Roaming\nvm\v7.5.0\node_modules\embark\lib\index.js:46:16)
    at Command.<anonymous> (C:\Users\User\AppData\Roaming\nvm\v7.5.0\node_modules\embark\lib\cmd.js:97:17)
    at Command.listener (C:\Users\User\AppData\Roaming\nvm\v7.5.0\node_modules\embark\node_modules\commander\index.js:301:8)
    at emitTwo (events.js:106:13)
    at Command.emit (events.js:192:7)
    at Command.parseArgs (C:\Users\User\AppData\Roaming\nvm\v7.5.0\node_modules\embark\node_modules\commander\index.js:615:12)
    at Command.parse (C:\Users\User\AppData\Roaming\nvm\v7.5.0\node_modules\embark\node_modules\commander\index.js:458:21)
    at Cmd.process (C:\Users\User\AppData\Roaming\nvm\v7.5.0\node_modules\embark\lib\cmd.js:26:11)

Issue Analytics

  • State:closed
  • Created 6 years ago
  • Comments:17

github_iconTop GitHub Comments

matkamcommented, Jun 22, 2017

Similar to @TortuePatate, I solved it by running: geth --datadir=".embark/development/datadir" --password config/development/password account new Embark should probably run this before account list

TortuePatatecommented, Jun 3, 2017

Hi there, I’ve got exactly the same problem but I’m running on Mac OS X. I tried to tweak the config/blockchain.json file on lines 13, 24 and 35 (“account”) but to no avail.

I’ve got an account properly set up on geth but it is not recognised when using embark.

Read more comments on GitHub >

github_iconTop Results From Across the Web

`embark blockchain` crashes on a new installation (Cannot ...
embark blockchain crashes on a new installation (Cannot read property '1' of null) #272. Closed. ripper234 opened this issue on May 24, ...
Read more >
embark-framework/Lobby - Gitter
So if your project was initialized with v4 but you then installed v5, ... You mean a freshly created one with latest embark...
Read more >
embark demo not working - Stack Overflow
The error is due to Blockchain.initChainAndGetAddress (/usr/local/lib/node_modules/embark/lib/blockchain.js:69:45) as shown in your error ...
Read more >
RStudio crashes with error: Cannot read property 'L' of null
RStudio is crashing every now and then. This is the rsession from Diagnostics. I'm seeing Cannot read property 'L' of null; frew times....
Read more >
Error with QABS crashing, TypeError - RPG Maker Forums
... the game crashes with a "TypeError: Cannot read property 'naturalWidth' of null" Could anyone help me find and possibly fix the issue?...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found