Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

conda environment installation takes many hours

See original GitHub issue

More of a conda issue than an atac-seq-pipeline issue, but wondering if the dev team has any suggestions.

running ./ takes many hours, stuck at solving environment step:

=== Installing pipeline's Conda environments ===
Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working...

(after ~6 hours the installation is successful)

I have tried the following to resolve the issue:

  • setting channel priority to strict / flexible/ false – using ‘strict’ priority gives package conflicts; flexible/false take a long time to resolve.

  • removing some of the strict package version specifications in requirements.txt (i.e. using a newer package version if available) – doesn’t seem to affect install speed

  • removing the ‘defaults’ conda channel from this line:

conda create -n ${CONDA_ENV_PY3} --file ${REQ_TXT_PY3} -y -c defaults -c r -c bioconda -c conda-forge

since the Iinternet seems to suggest that the defaults conda channel can be problematic.

I’m using conda 4.9.2

Thanks so much for any insights/advise!

Issue Analytics

  • State:open
  • Created 3 years ago
  • Comments:7 (2 by maintainers)

github_iconTop GitHub Comments

leepc12commented, Feb 20, 2021

Thanks @leipzig Added mamba to pipeline’s Conda installer. It’s like 5 times faster than Conda.

leepc12commented, Aug 19, 2021

If both mamba or no-mamba methods don’t work then please use Docker (caper run/submit ... --docker). If your cluster doesn’t allow it then try with Singularity (caper run/submit ... --singularity). Check if you have Singularity on your system.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Creating a conda environment is taking a long time #2132
Conda environment installation of the tool can take time but not several hours. You could try stopping, removing any partially created ...
Read more >
Stuck at Solving Environment on Anaconda - Stack Overflow
It might be taking long because of package version conflicts. My solution was to install some packages using pip instead of conda install....
Read more >
[need help] torch install on linux with conda takes more than ...
[need help] torch install on linux with conda takes more than 10 hours. solved by creating a conda virtual environment. I used conda...
Read more >
Installing with conda
To install conda packages, in the terminal or an Anaconda Prompt, run: ... Installing the files of a conda package into an environment...
Read more >
Working with Environments – Introduction to Conda for (Data ...
Installing a package into an existing environment. You can install a package into an existing environment using the conda install command. This command...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found