Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

An error with thrift on MacOS

See original GitHub issue
mkdir -p build
doxygen ./ && \
	cp -a ./gen-docs /Users/vonfry/codechecker/build/gen-docs
/Users/vonfry/codechecker/docs/ warning: explicit link request to 'CodeChecker' could not be resolved
if [ ! -d "/Users/vonfry/codechecker/build/gen-py" ]; then rm -rf /Users/vonfry/codechecker/build/gen-py; fi
if [ ! -d "/Users/vonfry/codechecker/build/gen-js" ]; then rm -rf /Users/vonfry/codechecker/build/gen-js; fi
thrift -r -o /Users/vonfry/codechecker/build -I thrift_api/ --gen py thrift_api/report_storage_server.thrift
thrift -r -o /Users/vonfry/codechecker/build -I thrift_api/ --gen py --gen js:query thrift_api/report_viewer_server.thrift
[FAILURE:generation:1] Error: unknown option js:query

If I remove :query, then the command like thrift -r -o /Users/vonfry/codechecker/build -I thrift_api/ --gen py --gen js thrift_api/report_viewer_server.thrift can be run and all other thing can be run correctly.

Issue Analytics

  • State:closed
  • Created 7 years ago
  • Comments:7 (5 by maintainers)

github_iconTop GitHub Comments

tmsblghcommented, Sep 24, 2017

I tried to build and use CodeChecker on Mac OS High Sierra (10.13 Beta) and it’s worked.

I only changed the thrift version from 0.9.1(or 2) to 0.10.0.

It was needed because I got an error with that version: “from thrift.Thrift import TType, TMessageType, TFrozenDict, TException, TApplicationException ImportError: cannot import name TFrozenDict”

But now it’s working fine, I think.

gyorbcommented, Feb 2, 2017

@VonFry did you manage to install and create a package with the modifications?

Read more comments on GitHub >

github_iconTop Results From Across the Web

Errors When Compiling C++ Application (Apache Thrift)
This problem occurs because automake generates the file "thrifty.hh" rather than "thrifty.h". So there are 2 ways to resolve this problem. 1) Downgrade...
Read more >
Cannot install thrift on Mac OSX 10.14.5 [configure: error
Description. I am installing apache thrift on a mac using the OS X setup guide I am able to install ...
Read more >
homebrew - How to install thrift 0.15 on big sur? - Ask Different
How can I install thrift 0.15.0 on Mac OS Big Sur? I followed the instructions as suggested in this answer but getting the...
Read more >
thrift - Homebrew Formulae
thrift. Install command: brew install thrift. Also known as: thrift@0.17 ... Analytics (macOS): ... Build Errors (30 days). thrift, 1. Installs (90 days)....
Read more >
Changelog for Apache Thrift 0.10.0 - ABI laboratory
... Bug * [THRIFT-1840] - Thrift Generated Code Causes Global Variable Leaks ... Librt does not exist on OS X * [THRIFT-3152] -...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found