Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

signature problem between scoold and para ?

See original GitHub issue

I’ve installed para and created an application for scoold, testing from another instance with para-cli works:

# para-cli read --id user@domain.example
    "id": "user@domain.example",
    "type": "sysprop",
    "name": "identifier",
    "stored": true,
    "indexed": true,
    "cached": true,
    "version": 0,
    "timestamp": 1563267351020,
    "appid": "scoold",
    "creatorid": "1061925487619608576",
    "votes": 0,
    "plural": "sysprops",
    "objectURI": "/sysprops/user%40domain.example",
    "key": "user@domain.example"

But when trying to login into scoold I get

2019-07-16 14:22:35 [ERROR] Request signature is invalid. - Request signature is invalid.

And para access log has:

10.xx.xx.xx4 - - [16/Jul/2019:14:22:35 +0000] "GET /v1/_id/user@domain.example HTTP/1.1" 403 65 "-" "Jersey/2.27 (HttpUrlConnection 1.8.0_212)"

Same para host, same access_key, same secret_key. Nothing relevant in para.log.

Signing up in scoold (email validation desactivated) works as I can see the user created in DynamoDB but with the same error as when trying to log in.

I’ve tried setting loglevel to trace, wich on scoold didn’t give me much more details, I didn’t found how to set para in debug mode.

How can I dig further why the scoold request is rejected by para ?

Sidenote: I was unsure the help request belongs here or on Para

Lately spotted difference, para-cli makes a GET to /v1/_batch where scoold’s para-client request /v1/_id

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:8 (4 by maintainers)

github_iconTop GitHub Comments

Tensibaicommented, Sep 18, 2019

Ok, after capturing on client side, server side before waf and server side just before para I think I found the problem.

Request on client side: GET /v1/_id/user%40domein HTTP/1.1\r\n Before WAF side: GET /v1/_id/user%40domein HTTP/1.1\r\n Before para (after WAF): GET /v1/_id/user@domein HTTP/1.1

The @ sign is decoded before retransmission and I suspect this is what cause the problem as the request signature has been done with urlencoded parameter.

I’ll have to dig on apache configuration to avoid that.

Thanks for the help, I’ll close the issue as it’s not due to para nor scoold.

albogdanocommented, Jul 17, 2019

Thanks for sharing this information. It could be helpful to others as well. 👍

Read more comments on GitHub >

github_iconTop Results From Across the Web

Erudika/scoold - Gitter
[ERROR] 400 - Failed to authenticate user with 'password'. Check if user is active [ERROR] 403 - Invalid signature for request GET /v1/_id/ ......
Read more >
Common problems with two-step verification for a work or ...
Common problems with two-step verification for a work or school account · I'm not being prompted for my second verification information · I...
Read more >
Frequently Asked Questions for Notaries Public
A notary must sign the notarial certificate using the same name that is listed on the commission issued by the secretary of state....
Read more >
Filling Out the FAFSA | 2022-2023 Federal Student Aid ...
However, correcting the SSN through the school or with the SAR will not change the ... 33, or 57 for Selective Service issues,...
Read more >
Troubleshoot issues with Gmail signatures - Google Support
Use a signature image in the recommended size. Common Gmail signature issues. Try these steps for general issues displaying and formatting Gmail signatures....
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found