Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error: Cannot find module 'eslint-plugin-react'

See original GitHub issue

Fresh global installation, first test and error 😦 Any ideas?

pawelgrzybek$ eslint js/script1.js
    throw err;

Error: Cannot find module 'eslint-plugin-react'
    at Function.Module._resolveFilename (module.js:336:15)
    at Function.Module._load (module.js:286:25)
    at Module.require (module.js:365:17)
    at require (module.js:384:17)
    at /usr/local/lib/node_modules/eslint/lib/cli-engine.js:116:26
    at Array.forEach (native)
    at loadPlugins (/usr/local/lib/node_modules/eslint/lib/cli-engine.js:107:21)
    at processText (/usr/local/lib/node_modules/eslint/lib/cli-engine.js:194:5)
    at processFile (/usr/local/lib/node_modules/eslint/lib/cli-engine.js:254:18)
    at executeOnFile (/usr/local/lib/node_modules/eslint/lib/cli-engine.js:540:23)

Issue Analytics

  • State:closed
  • Created 8 years ago
  • Comments:32 (9 by maintainers)

github_iconTop GitHub Comments

pawelgrzybekcommented, Sep 13, 2015

Sorry. That solved the problem. npm install -g eslint-plugin-react

liyaodongcommented, Apr 18, 2016

solved by ⬇️

$ cd ~/.atom/packages/linter-eslint
$ npm i eslint-plugin-react
Read more comments on GitHub >

github_iconTop Results From Across the Web

Dealing with "Failed to load plugin 'react' declared in '.eslintrc'
jsx This can happen for a couple of reasons: 1. The plugin name is spelled incorrectly in an ESLint configuration file (e.g. .eslintrc) ......
Read more >
Using globally installed "standard" package causes "Cannot ...
Using globally installed "standard" package causes "Cannot find module 'eslint-plugin-react'" error · npm install standard@14.3.1 -g · create a new project, ...
Read more >
eslint-plugin-react-hooks - npm
This ESLint plugin enforces the Rules of Hooks. It is a part of the Hooks API for React. Installation. Note: If you're using...
Read more >
eslint/eslint - Gitter
ESLint couldn't find the config "eslint: recommended" to extend from. ... But have parser error when I use RuleTester to test those rule....
Read more >
[eslint] failed to load plugin 'prettier' declared in '.eslintrc.json'
Error : Failed to load parser '@typescript-eslint/parser' declared in '.eslintrc.json': Cannot find module 'lodash/unescape' Require stack: ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found