Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

[Bug] "eg credentials create" hangs

See original GitHub issue

While following the Getting Started guide, at Part 3, Step 2, the following command hangs:

eg credentials create -c bob -t key-auth -q

It produces no output and never returns to the command prompt. Removing the -q option still produces no output (and still hangs).

This is a fresh installation of express-gateway (installed via npm install -g express-gateway as instructed) and using the app generated by eg gateway create. The gateway is running, and previous steps in the guide work properly (that is, the gateway is properly forwarding requests to httpbin). The gateway.config.yml file has been updated as directed (uncommenting the - key-auth: line) and the gateway restarted automatically when the change was saved.

Note that adding and listing users appears to work normally. Only creating credentials seems to cause problems. Also noteworthy is that the credentials do appear to get created in Redis; they just never get printed to the console and eg never exits. [ctrl]-[c] works to kill the process, but then I need to look up the new credentials manually. That’s going to get burdensome as I add more credentials for my current project.

Platform: Windows 10 Pro, build 17134.648, 64-bit. Node v11.11.0, npm 6.8.0. Redis 3.0.503 64-bit. All components are fresh installs, running natively (no docker or VM chicanery).

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:8 (4 by maintainers)

github_iconTop GitHub Comments

bshea5commented, Mar 16, 2020

I’m running into the same issue described above, on both node12 and 13 on Windows 10. Can this bug be re-opened?


XVincentXcommented, Jun 22, 2019

This does not appear to be an issue anymore in node12 — and it seems to be confirmed by our tests in Azure pipelines. Please reopen in case you’re still experiencing it.

Read more comments on GitHub >

github_iconTop Results From Across the Web

WebAuthn navigator.credentials.create hangs in browser ...
The Bugbug bot thinks this bug should belong to the 'Core::DOM: Web Authentication' component, and is moving the bug to that component. Please...
Read more >
Data source credentials hangs - Gateway not recognised
Solved: Hello, Data Source Credentials il always hanging on refresh. We have worked fine with the gateway for 2 months, on our server...
Read more >
Windows Defender Credential Guard - Known issues
Windows Defender Credential Guard - Known issues in Windows Enterprise. ... Guard blocks the use of these insecure protocols by design.
Read more >
Git commands in git bash requiring credentials freeze, and ...
I would expect the new Git Credentials Manager popup to come up ... fatal: The request was aborted: Could not create SSL/TLS secure...
Read more >
Data Server Manager (DSM) shows "Invalid Credentials ... - IBM
The string will tell you which profile connection failed, what is the error code, and if it is an invalid credential issue, then...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found