Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Add support for node 16 (current release) and scss

See original GitHub issue

Is your proposal related to a problem?

I start using node 16. My dependency node-scss require update to 6 version. When update this dependency and try build my app i have error:

Node Sass version 6.0.0 is incompatible with ^4.0.0 || ^5.0.0.

Describe the solution you’d like

We must update sass-loader to 10.2.0 version 😃

Describe alternatives you’ve considered

Try configure SCSS in CRA without node-scss because this package is deprecated :

Warning: LibSass and Node Sass are deprecated. While they will continue to receive maintenance releases indefinitely, there are no plans to add additional features or compatibility with any new CSS or Sass features. Projects that still use it should move onto Dart Sass.

Issue Analytics

  • State:open
  • Created 2 years ago
  • Reactions:4
  • Comments:5

github_iconTop GitHub Comments

BenJenkinsoncommented, Jun 29, 2021

Since react-scripts 4.0.2, you may use sass instead of node-sass to use SCSS stylesheets within your create-react-app app.

The documentation hasn’t yet been updated to match, but the instructions are the same. Just replace node-sass with sass:

$ npm install sass --save
maxburkecommented, Jun 21, 2021

Any updates to this issue?

Node 14 isn’t really an option for people using Apple Silicon computers; only node 15 or 16 are supported.

Read more comments on GitHub >

github_iconTop Results From Across the Web

node-sass - npm
Latest version : 8.0.0, last published: 2 months ago. Start using node-sass in your project by running `npm i node-sass`.
Read more >
Node Sass does not yet support your current environment
I have tried to install gulp-sass latest version with npm i gulp-sass --save-dev in the begining I got a lot of errors but...
Read more >
Node Sass does not yet support your current environment
Here is how you can fix node incompatibility error, using "Node Sass does not yet support your current environment" as an example.
Read more >
Dart Sass
To install Dart Sass on the command line, check out the installation ... Dart Sass supports a JavaScript API that aims to be...
Read more >
sass-loader - webpack - JS.ORG
Node Sass does not work with Yarn PnP feature and doesn't support @use rule. ... for Node.js less v16.0.0 if is possible (i.e....
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found