Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error after running create-react-app myapp

See original GitHub issue

Is this a bug report?

I think so!

Did you try recovering your dependencies?

npm–version 6.4.1

Which terms did you search for in User Guide?

create-react-app failing Error: Found incompatible module


Environment Info:

System: OS: OS X El Capitan 10.11.6 CPU: x64 Intel® Core™2 Duo CPU P8800 @ 2.66GHz Binaries: Node: 8.5.0 - ~/.nvm/versions/node/v8.5.0/bin/node Yarn: 1.9.4 - /usr/local/bin/yarn npm: 6.4.1 - ~/.nvm/versions/node/v8.5.0/bin/npm Browsers: Chrome: 69.0.3497.100 Safari: 11.1.2 npmPackages: react: Not Found react-dom: Not Found react-scripts: Not Found npmGlobalPackages: create-react-app: 2.0.3

Steps to Reproduce

  1. in my directory that have other react projects I run create-react-app tic-tac-toe

2.then i get these errors error css-loader@1.0.0: The engine “node” is incompatible with this module. Expected version “>= 6.9.0 <7.0.0 || >= 8.9.0”. error Found incompatible module

Aborting installation. Deleting generated file… package.json Deleting generated file… yarn.lock Deleting tic-tac-toe/ from /Users/mydirectory

Expected Behavior

(Write what you thought would happen.) I was expecting to see a folder made called tic-tac-toe, so I can enter it and run npm start

Actual Behavior

(Write what happened. Please add screenshots!)

Reproducible Demo

(Paste the link to an example project and exact instructions to reproduce the issue.)

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:5 (1 by maintainers)

github_iconTop GitHub Comments

onetoughcookie226commented, Oct 8, 2018

Try upgrading your node version to v8.9.0 or above.

It took me a while to figure out how to uninstall the old node version, as I had them in couple of places… but it’s fixed! thank you so much 😃

nerfologistcommented, Oct 8, 2018

Hi, I’m not a contributor but I think your node version is incompatible with css-loader. You might want to upgrade it to one of the mentioned acceptable versions, i.e. >= 6.9.0 < 7.0.0 || >= 8.9.0.

Read more comments on GitHub >

github_iconTop Results From Across the Web

reactjs - Error while creating new React app ("You are running ...
Solution 3: Run this command · npm uninstall -g create-react-app · npm cache clean --force · npm cache verify · npx create-react-app my-app....
Read more >
"npx create-react-app my-app" stopped working in 4.0.3 #10601
Describe the bug /tmp ▷ npx create-react-app my-app You are running `create-react-app` 4.0.1, which is behind the latest release (4.0.3).
Read more >
NPX Create React APP Not Working - YouTube
To create a new React App, we use npx command with create - react - app and then project name. It should create...
Read more >
create-react-app: command not found (React) error [Solved]
Use `npx` to solve the error create-react-app: command not found, e.g. `npx create-react-app my-app` or install the package globally by running `npm install ......
Read more >
Create a New React App
npx create-react-app my-app cd my-app npm start ... When you're ready to deploy to production, running npm run build will create an optimized...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found