Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error when calling npm start or yarn start

See original GitHub issue

Hello, I have been trying to create and work on an app and I have done an npm install -g create-react-app, and then executed create-react-app testName, and it finished successfully. But when I cd in to the project and run npm start or yarn start it fails with the following errors:

I’m having trouble interpreting the error logs, so if anyone has an idea I would appreciate it!

npm start:

0 info it worked if it ends with ok
1 verbose cli [ 'C:\\Program Files\\nodejs\\node.exe',
1 verbose cli   'C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js',
1 verbose cli   'start' ]
2 info using npm@4.6.1
3 info using node@v6.11.0
4 verbose run-script [ 'prestart', 'start', 'poststart' ]
5 info lifecycle test@0.1.0~prestart: test@0.1.0
6 silly lifecycle test@0.1.0~prestart: no script for prestart, continuing
7 info lifecycle test@0.1.0~start: test@0.1.0
8 verbose lifecycle test@0.1.0~start: unsafe-perm in lifecycle true
9 verbose lifecycle test@0.1.0~start: PATH: C:\Users\bhudi\AppData\Roaming\nvm\v6.11.0\node_modules\npm\bin\node-gyp-bin;C:\repos\test\node_modules\.bin;C:\ProgramData\Oracle\Java\javapath;C:\Program Files\Microsoft MPI\Bin\;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\dotnet\;C:\Program Files\Microsoft SQL Server\120\Tools\Binn\;C:\Program Files (x86)\Microsoft Emulator Manager\1.0\;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\130\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\Microsoft SQL Server\130\DTS\Binn\;C:\Program Files (x86)\Microsoft SQL Server\Client SDK\ODBC\130\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\130\DTS\Binn\;C:\Program Files (x86)\Microsoft SQL Server\130\Tools\Binn\ManagementStudio\;C:\Program Files (x86)\Microsoft Team Foundation Server 2013 Power Tools\Best Practices Analyzer\;C:\Program Files (x86)\Microsoft Team Foundation Server 2015 Power Tools\;C:\Program Files\Microsoft\Web Platform Installer\;C:\Program Files\TortoiseGit\bin;C:\Go\bin;";.";C:\Program Files\Git\cmd;C:\Program Files (x86)\Yarn\bin;C:\Users\bhudi\AppData\Roaming\nvm;C:\Program Files\nodejs;C:\Users\bhudi\AppData\Local\Microsoft\WindowsApps;C:\Program Files (x86)\Microsoft VS Code\bin;C:\Users\bhudi\AppData\Local\Yarn\bin;"C:\Users\bhudi\AppData\Local\Programs\Python\Python36-32\;C:\Users\bhudi\AppData\Local\Programs\Python\Python36-32\\Lib;C:\Users\bhudi\AppData\Local\Programs\Python\Python36-32\\DLLs;C:\Users\bhudi\AppData\Local\Programs\Python\Python36-32\\Lib\lib-tk;C:\Users\bhudi\AppData\Roaming\nvm;C:\Program Files\nodejs
10 verbose lifecycle test@0.1.0~start: CWD: C:\repos\test
11 silly lifecycle test@0.1.0~start: Args: [ '/d /s /c', 'react-scripts start' ]
12 silly lifecycle test@0.1.0~start: Returned: code: 3221225477  signal: null
13 info lifecycle test@0.1.0~start: Failed to exec start script
14 verbose stack Error: test@0.1.0 start: `react-scripts start`
14 verbose stack Exit status 3221225477
14 verbose stack     at EventEmitter.<anonymous> (C:\Users\bhudi\AppData\Roaming\nvm\v6.11.0\node_modules\npm\lib\utils\lifecycle.js:279:16)
14 verbose stack     at emitTwo (events.js:106:13)
14 verbose stack     at EventEmitter.emit (events.js:191:7)
14 verbose stack     at ChildProcess.<anonymous> (C:\Users\bhudi\AppData\Roaming\nvm\v6.11.0\node_modules\npm\lib\utils\spawn.js:40:14)
14 verbose stack     at emitTwo (events.js:106:13)
14 verbose stack     at ChildProcess.emit (events.js:191:7)
14 verbose stack     at maybeClose (internal/child_process.js:891:16)
14 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
15 verbose pkgid test@0.1.0
16 verbose cwd C:\repos\test
17 verbose Windows_NT 10.0.15063
18 verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "start"
19 verbose node v6.11.0
20 verbose npm  v4.6.1
21 error code ELIFECYCLE
22 error errno 3221225477
23 error test@0.1.0 start: `react-scripts start`
23 error Exit status 3221225477
24 error Failed at the test@0.1.0 start script.
24 error This is probably not a problem with npm. There is likely additional logging output above.
25 verbose exit [ 3221225477, true ]

yarn start:

yarn start v0.24.6
$ react-scripts start
error Command failed with exit code 3221225477.

*note: I use nvm and have tried with multiple versions, and nothing has helped. I’ve also uninstalled node and reinstalled, cleared cache, but it doesn’t seem to work.

  1. node -v: 6.11.0
  2. npm -v: 4.6.1
  3. yarn --version: 0.24.6
  4. npm ls react-scripts: react-scripts@1.0.7

Then, specify:

  1. Operating system: windows 10

Steps to Reproduce

  1. npm install -g create-react-app
  2. create-react-app test
  3. cd test
  4. npm start or yarn start

Expected Behavior

Expected it to host the app at localhost:3000

Actual Behavior

npm start snip yarn-start

Package Json

  "name": "",
  "version": "0.1.0",
  "private": true,
  "dependencies": {
    "react": "^15.6.1",
    "react-dom": "^15.6.1"
  "devDependencies": {
    "react-scripts": "^1.0.7"
  "scripts": {
    "start": "react-scripts start",
    "build": "react-scripts build",
    "test": "react-scripts test --env=jsdom",
    "eject": "react-scripts eject"

Issue Analytics

  • State:closed
  • Created 6 years ago
  • Comments:12 (2 by maintainers)

github_iconTop GitHub Comments

zaycodecommented, Nov 16, 2017

after you install the new dependency, you must run : npm install

belhassen07commented, Mar 19, 2018

did anyone got a solution for this? I tried using other node version , and shutdown the antivirus, that didn’t work.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Npm Error code when trying to run npm start or yarn start in ...
when I write npm start or yarn start , then I'm facing this type of error, node:internal/modules/cjs/loader:488 throw e; ...
Read more >
Start script missing error when running npm start
App with the scripts was in folder B. Folder B was in folder A. I open folder A in vscode and enter "npm...
Read more >
scripts - npm Docs
How npm handles the "scripts" field. ... package.json , simply create another script with a matching name and add "pre" or "post" to...
Read more >
Old React App Not Starting | Solution | Yarn Start Error
Old React App Not Starting | Solution | Yarn Start Error | NPM Start ... Now run the app using - yarn start...
Read more >
concurrently - npm
Start using concurrently in your project by running `npm i concurrently`. ... Global, npm i -g concurrently, yarn global add concurrently ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found