Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Failed to compile.TypeError: Cannot read property '0' of undefined

See original GitHub issue


Today we forked one of our new projects and we began noticing that our npm start, which runs react-scripts start, started failing with:

Failed to compile.                                                                                                                                                                                        [255/255]

Error in   TypeError: Cannot read property '0' of undefined
  - ExternalModuleFactoryPlugin.js:19 
  - NormalModuleFactory.js:159 
  - Tapable.js:75 NormalModuleFactory.applyPluginsAsyncWaterfall
  - NormalModuleFactory.js:144 NormalModuleFactory.create
  - Compilation.js:356 Compilation.process [as _addModuleChain]
  - Compilation.js:424 Compilation.process [as addEntry]
  - SingleEntryPlugin.js:24 Compiler.compiler.plugin
  - Tapable.js:107 Compiler.applyPluginsParallel
  - Compiler.js:394 Compiler.compile
  - Compiler.js:203 Compiler.runAsChild
  - compiler.js:70 
  - compiler.js:69 Object.compileTemplate
  - index.js:47 Compiler.<anonymous>

We started ripping off parts of our project to perhaps spot what could be happening and we ended up with the following folder structure:


Where the file contents are:


<!doctype html>
<html lang="en">                                                                                                                                                                                                   
    <div id="root"></div>


import React from 'react'
import ReactDOM from 'react-dom'


  "name": "client",
  "version": "0.1.0",                                                                                    
  "private": true,
  "dependencies": {
    "react": "^15.5.4",                                                                                  
    "react-dom": "^15.5.4"                                                                               
  "devDependencies": {                                                                                   
    "babel-eslint": "^7.2.3",                                                                            
    "eslint": "^3.19.0",                                                                                 
    "eslint-plugin-import": "^2.2.0",                                                                    
    "eslint-plugin-react": "^6.10.3",
    "react-scripts": "0.9.5",                                                                                                                                                                                      
    "webpack": "^2.4.1"                                                                                  
  "scripts": {                                                                                           
    "start": "react-scripts start"                                                                       

The same error still happens. I had to install stuff like webpack and eslint so it could let me run it, or at least try to. Just in case. Remember that it happens when I try to npm start.

Can you reproduce the problem with latest npm?

Yes. I’m using npm 4.5.0


Run these commands in the project folder and fill in their results:

  1. npm ls react-scripts (if you haven’t ejected): react-scripts@0.9.5
  2. node -v: v7.7.3
  3. npm -v: 4.5.0

Then, specify:

  1. Operating system: No LSB modules are available. Distributor ID: Debian Description: Debian GNU/Linux 8.7 (jessie) Release: 8.7 Codename: jessie

  2. Browser and version: Not reaching the browser at this point.

Issue Analytics

  • State:closed
  • Created 6 years ago
  • Comments:22 (9 by maintainers)

github_iconTop GitHub Comments

Timercommented, Jul 24, 2017

@ibmua unfortunately this is a bug of package managers, not Create React App. The proper solution here is to separate your CRA scaffolded application into a separate folder (see monorepo) until package managers can resolve their bugs.

If you are installing webpack alongside of react-scripts, it is completely expected to not work as of now.

Timercommented, May 17, 2017

Neat! I believe it was fixed in d6dbfc0353f5595b9bfd389a7694214744e1711a and 50aaae6c1c01ec078c2ef5205652c69a4d46aeb5. Yarn recently changed it’s package hoisting / etc so it probably caused this.

Read more comments on GitHub >

github_iconTop Results From Across the Web

How to Prevent the Error: Cannot Read Property '0' of Undefined
A guide on how to prevent the error "cannot Read Property '0' of Undefined", covering techniques such as try, catch, using const over...
Read more >
How To Fix Cannot read Property '0' of Undefined in JS
To resolve your TypeError: Cannot read properties of undefined (reading '0') , go through these steps: Ensure you are using the correct ...
Read more >
ERROR TypeError: Cannot read property '0' of undefined
This Api call this.http.get(this.url).toPromise() is an asynchronous task so when your app renders HeaderComponent this property public ...
Read more >
"Cannot read property "0" from undefined:" Error Message
Hello @Ankur Bawiskar In Servicenow logs, we are getting this below Error; Cannot read property "0" from undefined:
Read more >
[SOLVED] Cannot Read Property '0' of Undefined in JavaScript
The “cannot read property '0' of undefined” error occurs when you try to access the 0 index of an array-like variable, but the...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found