Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Misleading statement: "You almost never need to update create-react-app itself"

See original GitHub issue

Is this a bug report?

No, it’s about the documentation.

Which terms did you search for in User Guide?

misleading documentation update

A few weeks I started a new project with the new version of create-react-app --typescript. In the process I intended to update create-react-app. I searched about it and arrived at this page (Create-React-App documenation), where I read:

You almost never need to update create-react-app itself: it delegates all the setup to react-scripts.

When you run create-react-app, it always creates the project with the latest version of react-scripts so you’ll get all the new features and improvements in newly created apps automatically.

I figured out updating CRA is not necessary. As a result the new project of create-react-app was not created properly (see here). Files were not created with .tsx extension, typescript and type libraries were not installed etc.

I also had another related bug - running npx create-react-app --info produced an error. Yesterday I updated Create-React-App itself and that solved the bugs. I had a relatively updated version of create react app as I reinstalled everything on this computer 4 months ago.

Can you please remove the statements above, or update them?

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Reactions:1
  • Comments:7 (7 by maintainers)

github_iconTop GitHub Comments

carpbencommented, Jan 8, 2019

I just visitied Installtion instructions have changed; I think in the past users were recommended to run something like `npm i -g create-react-app". So I guess this is the source of the problem.

ianschmitzcommented, Jan 9, 2019

I’ve created #6157 to hopefully clear this up. It’s come up a number of times recently after the addition of the --typescript option to the CLI. For users that have an older version installed globally, npx will use that cached version.

Read more comments on GitHub >

github_iconTop Results From Across the Web

create-react-app doesn't have any effect - Stack Overflow
I tried to reinstall npm, update node, clean cache, and other things. Can anyone help with this? reactjs · react-native · npm.
Read more >
STOP Using Create React App - YouTube
Create React App is a plague and we're here to cure it. Please use Vite, NextJS, or Remix instead. Seriously, anything is better...
Read more >
Updating to New Releases - Create React App
Create React App creates the project with the latest version of react-scripts so you'll get all the new features and improvements in newly ......
Read more >
How to work with React the right way to avoid some common ...
Warning: Can't call setState (or forceUpdate) on an unmounted component. This is a no-op, but it indicates a memory leak in your application....
Read more >
Hooks FAQ - React
Hooks won't work if you forget to update, for example, React DOM. ... If you need to test a custom Hook, you can...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found