Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

No files matching 'path/to/app/src/.' were found.

See original GitHub issue

Describe the bug

I have recently installed a new project with npx create-react-app my-app and tried to run it with npm start my-app. There is an empty space in the path, in example:

'C:/some folder/my-app'

I receive a message:

Failed to compile
No files matching 'C:/some folder/my-app/src/.' were found.

If i use a path without empty spaces for my app, everything works fine. Is important to note that this error started yesterday.

Which terms did you search for in User Guide?

I searched in the recent issues, but not found anything relevant. This problem started to happen yesterday, so I think it has to do with the new version, the previous one works fine.


The problem persist in Ubuntu and Windows, I tested in both. npm 6.14.5 node 12.18.2

Steps to reproduce

  1. $mkdir ‘./my project/app’
  2. $cd ‘my project/app’
  3. $npx create-react-app my-app
  4. $cd my-app
  5. $npm run start

Expected behavior

New browser window opens with the React logo.

Actual behavior

Failed to compile

No files matching 'C:/my project/app/src/.' were found.

This error occurred during the build time and cannot be dismissed.


Issue Analytics

  • State:closed
  • Created 3 years ago
  • Reactions:21
  • Comments:31 (1 by maintainers)

github_iconTop GitHub Comments

elcontrastadorcommented, Oct 28, 2020

Check to ensure your ENTIRE absolute path to your project has no spaces or non-standard metacharacters in it…or move/re-create the project to a folder that complies. The main dropbox folder is a common culprit for spaces and parentheses. This is absolutely a bug and should be fixed.

kaganince1commented, Oct 25, 2020

I found that if you Ctrl + C in the terminal and do npm start again, this error does not show again.

Tried it many times didnt work for me

Read more comments on GitHub >

github_iconTop Results From Across the Web

Error: No files matching '.' were found. · Issue #1749 - GitHub
What operating system, Node.js, and npm version? ... What happened? If there is no file to be checked in the project, this error...
Read more >
"No files matching the pattern "src" were found." when using ...
I've just set up a create-react-app project with typescript. I've added eslint with npx eslint --init . When I run npx eslint src/...
Read more >
"No files matching the pattern" then "Module build failed ...
I first ran into the No files matching the pattern "/Volumes/…/resources/assets/**/*.s?(c|a)ss" were found error. Searching the forum, the fix ...
Read more >
ANS1092W error with restore operation using non-root user.
Running a client restore as a non-root user logs the ANS1092W error. ... ANS1092W No files matching search criteria were found
Read more >
eslint/eslint - Gitter
Running yarn lint on Linux/Mac works, but on Windows I get this error: No files matching the pattern "'**/*.ts'" were found.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found