Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

npx create-react-app my-app is isn't installing the packages and i try uninstalling npm using -g but still.

See original GitHub issue

here is the problem i get everytime i try to install the packages. Can you please help? i willl be glad…

C:\Users\AHMED\Desktop\robohash\trove-app>npx create-react-app trove

You are running create-react-app 4.0.0, which is behind the latest release (4.0.1).

We no longer support global installation of Create React App.

Please remove any global installs with one of the following commands:

  • npm uninstall -g create-react-app
  • yarn global remove create-react-app

The latest instructions for creating a new app can be found here:

npm ERR! code 1 npm ERR! path C:\Users\AHMED\Desktop\robohash\trove-app npm ERR! command failed npm ERR! command C:\WINDOWS\system32\cmd.exe /d /s /c ““create-react-app” “trove””

npm ERR! A complete log of this run can be found in: npm ERR! C:\Users\AHMED\AppData\Local\npm-cache_logs\2020-11-24T00_04_00_794Z-debug.log


Issue Analytics

  • State:closed
  • Created 3 years ago
  • Reactions:2
  • Comments:6

github_iconTop GitHub Comments

kristianpedersencommented, Nov 27, 2020

Edit: Try @willwearing’s suggestion below instead: npm install -g npm@latest

My original post:

I’m getting the same error on MacOS 11.0.1, and I’ve always used npx.

This works for me, but I have to type it every time: npx create-react-app@4.0.1 my-app.

salimdasoncommented, Nov 28, 2020
  1. First, you’ll need to uninstall “create-react-app” using the “npm uninstall -g create-react-app” command.
  2. Run “npx create-react-app my-app” each time you want to create a new React app. Hope you find this helpful
Read more comments on GitHub >

github_iconTop Results From Across the Web

Issues with uninstalling create-react-app - Stack Overflow
After globally uninstalling create-react-app , I was still getting an error that my create-react-app was out of date.
Read more >
npm uninstall -g create-react-app · Issue #8097 - GitHub
I had to do the following: After uninstalling it with npm uninstall -g create-react-app , check whether you still have it "installed" with...
Read more >
What To Do if create-react-app Doesn't Work
1. npm uninstall -g create-react-app. This is the npm command to uninstall your global installation of create-react-app .
Read more >
Create a New React App
Create React App is a comfortable environment for learning React, and is the best way to start building a new single-page application in...
Read more >
npx create-react-app not working? Here's the solution.
Thank you!! I was trying everything: npm uninstall -g create-react-app; npm update npx. And nothing worked, until I found your article.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found