Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

React App Compilation failing due to missing eslint cache file

See original GitHub issue

Can you reproduce the problem with latest npm?



React app compilation is periodically / intermittently failing with the error due to a change in eslint-caching as per #1578. A cache file is missing in the node_modules directory

Expected behavior

App should compile with no errors

Actual behavior

The create-react-scripts throw the following error when compiling on file change:

Module build failed: Error: ENOENT: no such file or directory, open '/app/client/node_modules/.cache/eslint-loader/data.json'

On closer inspection this seems to happen when I rename / add a new file. However it happens so randomly it has been difficult to pin down.


Run these commands in the project folder and fill in their results:

  1. npm ls react-scripts (if you haven’t ejected):
npm info it worked if it ends with ok
npm info using npm@4.1.2
npm info using node@v7.6.0
client@0.1.0 /app/client
`-- react-scripts@0.9.2

npm info ok
  1. node -v:
  1. npm -v:
  1. Operating system: OSX running Docker Image: which is based off of official node images

  2. Browser and version: Chrome 56.0.2924.87 (64-bit)

Ping @Timer - Here’s the issue. I can’t provide my project as its on a private Git server internally but will do all I can to help troubleshoot. Hope this helps!

Issue Analytics

  • State:closed
  • Created 7 years ago
  • Comments:37 (18 by maintainers)

github_iconTop GitHub Comments

viankakrisnacommented, Feb 28, 2017

deleted react-scripts patch repo and gists so we can focus on @dylanrhysscott please update to 0.9.3!

dylanrhysscottcommented, Mar 2, 2017

@viankakrisna Just bumped the version on my project - all resolved!

Read more comments on GitHub >

github_iconTop Results From Across the Web

My create-react-app is failing to compile due to ESLint error
This issue has been fixed in the react-scipts:"4.0.3" but, the eslint errors present in the project are not converted to warnings by default....
Read more >
Tried to deploy app on React + Typescript. Can't see exact ...
Can't see exact error why it can't compile, only ESLint advices ... PM: Fetching cached dependencies 11:21:14 PM: Failed to fetch cache, ...
Read more >
ESLint | IntelliJ IDEA Documentation - JetBrains
IntelliJ IDEA integrates with ESLint which brings a wide range of linting rules that can also be extended with plugins.
Read more >
eslint-config-react-app - npm
First, install this package and ESLint. npm install --save-dev eslint-config-react-app eslint@^8.0.0. Then create a file named ...
Read more >
failed to load config "react-app/jest" to extend from -
Failed to compile. eslint Failed to load config "react-app" to extend from. Referenced from: C:/code/React_Training/react-complete-guide/package.json ERROR ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found