Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

`yarn start` fails with error message

See original GitHub issue


yarn startfails with below message

yarn start v0.15.1 $ “react-scripts start” sh: react-scripts start: command not found error Command failed with exit code 127. info Visit for documentation about this command.

Expected behavior

According to the prompt after creating a project, yarn star should work.

We suggest that you begin by typing: cd xyz yarn start Happy hacking!

Actual behavior

Tell us what actually happens.


node -v

npm -v

create-react-app --version                                                                                                                 
create-react-app version: 1.0.0

Operating system: MacOSX 10.12.1

Reproducible Demo

  1. Globally install create-react-app and create one project called xyz.
  2. Follow the prompt instructions;
  3. yarn start fails, but npm start works.

Issue Analytics

  • State:closed
  • Created 7 years ago
  • Comments:12 (1 by maintainers)

github_iconTop GitHub Comments

zverbatimcommented, Jun 28, 2017

worked for me after running just the command yarn in project folder

peggyc3commented, Oct 24, 2017

I had a similar problem, caused by installing a package using npm instead of yarn, which is what I was using for this project. I got the react script not found error message and the server would not start. To fix it, I ran yarn, then ran yarn start and the server restarted. SUCCESS 😃

Read more comments on GitHub >

github_iconTop Results From Across the Web

Error: yarn start - error Command "start" not found
this error happens when you're running yarn start in a wrong directory instead of the root directory where package.json is. if they didn't...
Read more >
Error Codes | Yarn - Package Manager
This error is usually caused by a Yarn plugin being missing. YN0011 - FETCHER_NOT_FOUND. A fetcher cannot be found for the given package....
Read more >
Yarn Start not working : r/react - Reddit
First, it sounds like you have not defined a start script in your package.json. You should add the "start" script in the "scripts"...
Read more >
Getting error messages when running yarn commands
json', requestPath: 'yargs' } error Command failed with exit code 1. info Visit for documentation about this ...
Read more >
Old React App Not Starting | Solution | Yarn Start Error
I created this app one and half year ago. I used create-reat-app to start this react project. Node JS has been upgraded, react...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found