Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Could not load assembly Steamworks

See original GitHub issue

Describe the bug

I have a CI server that build my game using this Docker image (running on Linux environment).

Here is the error I get:

Start importing Assets/Plugins/Facepunch.Steamworks/redistributable_bin/linux64/ using Guid(a3b75fd2a03fb3149b60c2040555c3fe) Importer(-1,00000000000000000000000000000000)  -> (target hash: '3a1ede127da4047ae756f122896527e5') in 0.558551 seconds
Start importing Assets/Plugins/Facepunch.Steamworks/Facepunch.Steamworks.Win64.dll using Guid(b3ad7ccc15f481747842885a21b7b4ab) Importer(-1,00000000000000000000000000000000)  -> (target hash: '6020022bb5ae380b501cbc721695cfc8') in 0.180582 seconds
Start importing Assets/Plugins/Facepunch.Steamworks/redistributable_bin/steam_api.dll using Guid(f47308500f9b7734392a75ff281c7457) Importer(-1,00000000000000000000000000000000)  -> (target hash: '719a622d266dbbec9cbfcaad3bad4d71') in 0.004972 seconds
Start importing Assets/Plugins/Facepunch.Steamworks/Facepunch.Steamworks.Win32.dll using Guid(fb41692bc4208c0449c96c0576331408) Importer(-1,00000000000000000000000000000000)  -> (target hash: 'fe5b7939d222023beac8cd8060e94dbb') in 0.050592 seconds
Start importing Assets/Plugins/Facepunch.Steamworks/Facepunch.Steamworks.Posix.dll using Guid(fc89a528dd38bd04a90af929e9c0f80e) Importer(-1,00000000000000000000000000000000)  -> (target hash: '2a7bfaf641c3b093beb1fbf65a32e7b3') in 0.040369 seconds
Start importing Assets/Plugins/Facepunch.Steamworks/redistributable_bin/osx/libsteam_api.bundle using Guid(7d6647fb9d80f5b4f9b2ff1378756bee) Importer(-1,00000000000000000000000000000000)  -> (target hash: 'c1bba71b19b5f87752cfef8071e94739') in 0.004326 seconds
Start importing Assets/Plugins/Facepunch.Steamworks/redistributable_bin/linux32/ using Guid(fd99b19e202e95a44ace17e10bac2feb) Importer(-1,00000000000000000000000000000000)  -> (target hash: '8593427794e4856ded643d9bc44805d1') in 0.004315 seconds
Start importing Assets/Plugins/Facepunch.Steamworks/redistributable_bin/win64/steam_api64.dll using Guid(cf5718c4ee1c31e458f8a58a77f4eef0) Importer(-1,00000000000000000000000000000000)  -> (target hash: '2489f72496502944a3b6a508fcacae29') in 0.004956 seconds
Begin MonoManager ReloadAssembly
Symbol file LoadedFromMemory doesn't match image /builds/Team/Project/Library/PackageCache/com.unity.ext.nunit@1.0.0/net35/unity-custom/nunit.framework.dll
Native extension for LinuxStandalone target not found
Native extension for WindowsStandalone target not found
Refreshing native plugins compatible for Editor in 160.22 ms, found 1 plugins.
Preloading 0 native plugins for Editor in 0.00 ms.
Could not load assembly Steamworks, Version=, Culture=neutral, PublicKeyToken=null

However I have no problem to make local build on Windows.

For the installation, I only did the steps described here.

I’m using Unity 2020.1.0f1

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:8

github_iconTop GitHub Comments

Noxaluscommented, Aug 12, 2020

OK, I confirm the solution given in my previous message works.

Before to made the change, I couldn’t compile neither for Linux nor Windows. But if I make the change, it’s ok for both target platforms.

Doing the same change on my project, the issue is fixed too when the CI builds the project in the Docker container too.

Here are the changes detected by Git:


I suppose that the issue will be the same if the host environment to build is a Mac OS, but for now the solution is good enough for me. 👍

linjmeyercommented, Jan 3, 2021

Thankyou @Noxalus! I had the same issue. Everything worked locally, but in CI I was getting namespace not found 'steamworks'. After changing the editor .dll platform to Linux from OSX all three of my CI builds (OSX, Windows, Linux) began working.

Read more comments on GitHub >

github_iconTop Results From Across the Web

[1.4] Game Doesn't Launch - Steamworks.NET failed to load
BadImageFormatException : Could not load file or assembly 'Steamworks.NET, Version=, Culture=neutral, PublicKeyToken=null'.
Read more >
Which mod would cause this error: Could not load type ' ...
A Mod caused an error [ModException] Details: System.TypeLoadException: Could not load type 'ColossalFramework.Steamworks.Achievement' from assembly ...
Read more >
Could not load file or assembly 'Facepunch.Steamworks. ...
It looks like you tried to install the Linux build on the Windows server. Stigma. Original Poster.
Read more >
Could not load file or assembly or one of its dependencies
At 99% the Could not load file or assembly or one of its dependencies problem is caused by dependencies! I suggest you follow...
Read more >
Could not load type 'Facepunch.Steamworks.ServerInit'
The server does not work after the update TypeLoadException: Could not load type 'Facepunch.Steamworks.ServerInit' from assembly 'Facepunch.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found