Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

rake assets:precompile error

See original GitHub issue

Expected Behavior

compilation OK

Actual Behavior

compilation error at docker-compose run web rake assets:precompile

-> when running no webpage joingable

🚨  /farmbot/node_modules/i18next/dist/es/defaults.js:1:9: Export 'get' is not defined (1:9)
> 1 | export { get };
    |         ^
  2 | function get() {
  3 |   return {
  4 |     debug: false,
rake aborted!
Command failed with status (1): [node_modules/parcel-bundler/bin/cli.js bui...]
/farmbot/lib/tasks/api.rake:62:in `parcel'
/farmbot/lib/tasks/api.rake:77:in `block (2 levels) in <top (required)>'
/bundle/gems/rake-12.3.2/exe/rake:27:in `<top (required)>'
Tasks: TOP => assets:precompile => api:parcel_compile
(See full trace by running task with --trace)

Steps to Reproduce

On a fresh new ubuntu server 18.10 following the master procedure: I get some warnings with :docker-compose run web npm install

npm WARN react-addons-test-utils@15.6.2 requires a peer of react-dom@^15.4.2 but none is installed. You must install peer dependencies yourself.
npm WARN ts-jest@23.10.5 requires a peer of jest@>=22 <24 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.7 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.7: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

but I don’t know if it’s related, and after that I get the error with docker-compose run web rake assets:precompile

Results of git log -1

commit 26e98cb389551098eac27b0722fe388c19595a5a (HEAD -> master, origin/master) Merge: d59c907 cc00c74 Author: Rick Carlino Date: Fri Mar 8 09:21:25 2019 -0600

Merge pull request #1127 from RickCarlino/nerveshub_hotfix

HOTFIX: Background worker NPE

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:5 (5 by maintainers)

github_iconTop GitHub Comments

nicmelcommented, May 9, 2019

I’m back, no time until today to look a it. I’m trying it today It works.


RickCarlinocommented, Apr 5, 2019

@nicmel QA is done and v7.2.3 has been released. Please let me know if you have any issues with the latest version.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Ruby on Rails Rake assets:precompile error - Stack Overflow
I ran into this issue as well and I resolved it by doing the following: Open up config/environments/production.rb and make sure the ...
Read more >
rake assets:precompile fails #602 - rails/webpacker - GitHub
Everything seems to be working fine in development, however when trying to deploy I'm getting an error. Output of running command is as...
Read more >
Rake assets:precompile ERROR - Sharetribe
When I ran NODE_ENV=production bundle exec rake assets:precompile It gave me an error. It said: Rake Aborted! Command failed with status (1): [ ......
Read more >
Rails 3 deploys now error out on failed `rake assets:precompile`
When deploying a Rails 3 app, if rake assets:precompile is detected as a valid rake task, and no asset manifest file is present...
Read more >
Failing assets:precompile without error output - Troubleshooting
I have been trying to execute: RAILS_ENV=production bundle exec rails assets:precompile But I keep getting the following output: yarn install v1.16.0 [.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found