Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Spotcast won't load after upgrade to 2022.4.6

See original GitHub issue

Bug Ticket

Describe the bug

The upgrade to 2022.4 caused a problem with both nest and Spotcast with Spotcast showing the error below. It was working prior to the upgrade

  • Using latest version of spotcast
  • I have setup the Spotify integration in Home Assistant
  • I am using multiple accounts
  • Using latest stable version of Home Assistant
  • I have Spotify Premium
  • I’m attaching relevant logs with level debug for component spotcast (see README)
  • I’m using entity_id in the service call and have tried device_name but the issue remains


  • Installation type: [|Supervised|]
  • HA version: [ 2022.4.6]
  • spotcast version: [3.6.29 ]


  sp_dc:  ####
  sp_key: ####
      sp_dc: ####
      sp_key: ####
      sp_dc: ####
      sp_key: ####

Service Call

If relevant, provide a yaml of the service call or explain the action taken to replicate the issue.

Additional context

Logger: homeassistant.loader Source: components/cast/ First occurred: 11:15:29 AM (1 occurrences) Last logged: 11:15:29 AM

Unexpected exception importing component custom_components.spotcast
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 584, in get_component
    cache[self.domain] = importlib.import_module(self.pkg_path)
  File "/usr/local/lib/python3.9/importlib/", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 850, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/config/custom_components/spotcast/", line 44, in <module>
    from .helpers import async_wrap, get_cast_devices, get_spotify_devices
  File "/config/custom_components/spotcast/", line 11, in <module>
    from homeassistant.components.cast.media_player import CastDevice
  File "/usr/src/homeassistant/homeassistant/components/cast/", line 7, in <module>
    from pychromecast import Chromecast
  File "/usr/local/lib/python3.9/site-packages/pychromecast/", line 14, in <module>
    from . import socket_client
  File "/usr/local/lib/python3.9/site-packages/pychromecast/", line 23, in <module>
    from . import cast_channel_pb2
  File "/usr/local/lib/python3.9/site-packages/pychromecast/", line 20, in <module>
    _SIGNATUREALGORITHM = DESCRIPTOR.enum_types_by_name['SignatureAlgorithm']
AttributeError: 'NoneType' object has no attribute 'enum_types_by_name'

Issue Analytics

  • State:open
  • Created a year ago
  • Comments:10

github_iconTop GitHub Comments

fcussoncommented, Apr 25, 2022

Yep I have that, however, I can’t launch python. I get this error. zsh: command not found: python

Ok the difference between the docker and the hassio version seems to be quite different now. I’ll set up a dummy raspberry pi install and try Spotcast on it.

codypetcommented, Jun 5, 2022

Any new news on this. I tried instead of typing python, Python3 and got "No module named ‘pychromecast’ So I’m at a loss as to what’s going on. Like I said, it was working for 2022.3.8.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Issues · fondberg/spotcast - GitHub
Spotcast won't load after upgrade to 2022.4.6 bug Something isn't working dependency issue issue exist because of dependency not the project itself.
Read more >
spotcast - Bountysource
Spotcast won't load after upgrade to 2022.4.6 $ 0 ... Created 7 months ago in fondberg/spotcast with 10 comments. Bug Ticket. Describe the...
Read more >
Spotcast doesn't work after upgrading to HA 2021.4
Hi, I just upgraded HA to the latest release. everything went well except for Spotify integration (Spotcast integration from HACS).
Read more >
30 Things Happening For Disneyland Paris' 30th Anniversary
Plus, a short post-show will be on display after Illuminations. ... While Disneyland Paris itself is turning 30 this year, we can't forget ......
Read more >
spotcast - bytemeta
spotcast repo issues. ... Spotcast is not working when using cast as custom component. VaillantHassIo ... Spotcast won't load after upgrade to 2022.4.6....
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found