Rename variables that start with opt_
See original GitHub issueThis is a good first issue for people who want to start contributing to this repository.
Category
Plugins
Component
All plugins
Describe the bug
The existing code uses opt_
as a prefix for optional parameter names. This is based on old recommendations in Google’s style guide.
The style guide now says that parameter names should all be written in lowerCamelCase
.
You can see all of the places where the wrong naming convention is used by running npm run lint
from the root of the repository.
Steps to fix
- Run
npm run lint
from the root of the repository. - Choose a file with lint errors due to camelcase issues.
- Replace all names:
opt_someParameterName
should becomeoptSomeParameterName
. - Make a pull request.
Issue Analytics
- State:
- Created 2 years ago
- Reactions:2
- Comments:11 (9 by maintainers)
Top Results From Across the Web
Rename refactorings | IntelliJ IDEA Documentation - JetBrains
Use the Rename refactoring to change names of symbols, files, directories, packages, modules and all the references to them throughout code.
Read more >rename variables in the middle of the scope - c++
I want to change a variable name in middle of its scope for readability issue. For example: while(condition){ std::vector<big_type> ...
Read more >Renaming variables that don't have a space to have a space
Hello - I have a request to change all of the variable names for a report that I created. I will be using...
Read more >select & rename R Functions of dplyr Package (2 Examples)
In this R tutorial you'll learn how to select and rename variables with the select() and rename() functions of the dplyr package. The...
Read more >Renaming destructured variables in ES6 | by Valter Júnior
A property can be unpacked from an object and assigned to a variable with a different name than the object property. That's it!...
Read more >Top Related Medium Post
No results found
Top Related StackOverflow Question
No results found
Troubleshoot Live Code
Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start FreeTop Related Reddit Thread
No results found
Top Related Hackernoon Post
No results found
Top Related Tweet
No results found
Top Related Dev.to Post
No results found
Top Related Hashnode Post
No results found
Top GitHub Comments
@rachel-fenichel ok Also just to clarify By
You mean that these changes only need to be made in Plugins folder right?
If the names are conflicting, pick a new name for either the parameter or the variable name in the function–hopefully most of these are straightforward.
For lint not detecting every instance: Yes, manually using find and replace is fine as well.
Cheers, Rachel