Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Pushing the image to Docker Hub takes a long time

See original GitHub issue


  • Jib version: 1.5.0
  • Build tool: Gradle 5.6.2
  • OS: MacOSX 10.14.6

Description of the issue:

Push the image to Docker Hub initially takes extremely long (almost 5 mins). Subsequent push operations are much faster (seconds).

Expected behavior:

Pushing an image to Docker Hub should match the execution time when using Docker Engine.

Steps to reproduce:

  1. Clone
  2. Execute ./gradlew jib

Log output:

$ ./gradlew jib

> Task :jib

Containerizing application to bmuschko/todo-web-service:1.0.0...

Container entrypoint set to [java, -cp, /app/resources:/app/classes:/app/libs/*, com.bmuschko.todo.webservice.Application]

Built and pushed image as bmuschko/todo-web-service:1.0.0
Executing tasks:
[============================  ] 92.5% complete
> preparing application layer pushers

3 actionable tasks: 1 executed, 2 up-to-date

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Reactions:1
  • Comments:16 (9 by maintainers)

github_iconTop GitHub Comments

bmuschkocommented, Sep 13, 2019

@TadCordle Thanks. I tried it out and its close to the numbers I see with version 1.4.0.

kalapraveen-micommented, Sep 12, 2019

@kalapraveen-mi are you using <allowInsecureRegistries> by any chance? If that is the case, I worry that 1.4.0 might be the last version that may seem to “work” (in a very inefficient way) in your case. I could be wrong about your case though.

@chanseokoh No, I am not using any such tag and logged into Docker container on Mac. We are using Jib plugin and is run as part of “deploy” phase in the following way:


Now, when I run the build of the project version contains SNAPSHOT it gets pushed effortlessly as it always does. However, if the ${project.version} contains a release it struggles and ends up with a credentials error. The same code works if I explicitly specify the version 1.4.0.

We push to dockerhub by the way. Hope this info helps. Thank you very much!

Read more comments on GitHub >

github_iconTop Results From Across the Web

Docker push takes a really long time - Stack Overflow
The main culprit is the docker push step. For both Docker Hub and, it takes an unrealistically long time to push images....
Read more >
Push to docker hub seems very slow
My pushes seems excessively slow. (it takes nearly 10 minutes to push a 16 MB image). I found a lot of posts referring...
Read more >
Docker push is taking forever - Reddit
I've restarted Docker and it still takes forever. I'm trying to upload a 177.7 MB image and it has only gone through 5.567...
Read more >
How We Cut Our Docker Push Time by 90% - DZone DevOps
This push can be frustratingly slow, especially on home networks. Waiting 30 minutes for the image to upload before being able to start ......
Read more >
Six Ways to Build Docker Images Faster (Even in Seconds)
Something had to be done about that. We decided to figure out why building Docker images took so long and how to fix...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found