Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

[devnet] Problem connecting wallet to sandbox

See original GitHub issue

Describe the bug I am running devnet and connecting to the local devnet explorer. When I try to connect my wallet, it seems to work, then a different address appears to be connected. See video.

After some experimentation, I tried signing out of the wallet, clearing the cache, and relaunching devnet and found that instead of this problem, after connecting the wallet, the sandbox never loaded, then after a delay, I get “This page is missing” (appears to be the same problem as #647).

To Reproduce Start devnet, for example, clone and then run clarinet integrate, then open http://localhost:8000/sandbox/deploy.

Expected behavior I expect to be able to properly login to the devnet explorer sandbox and call a function.

Issue Analytics

  • State:open
  • Created 2 years ago
  • Reactions:1
  • Comments:7 (2 by maintainers)

github_iconTop GitHub Comments

He1DArcommented, Apr 6, 2022

@fbwoolf Sounds good. Is there a PR for that work we can link here, and if not, can we open a WIP one?

It’s not ready yet.

fbwoolfcommented, Apr 3, 2022

@markmhx I’ve been reproducing these devnet issues over the weekend, it seems like @He1DAr’s work on refactoring the network mode state (which touches the sandbox code) may resolve many of these. I can check all these again once that work is ready to see if we can close these. If anything, it will be easier to fix these once that work is done.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Changing a connected wallet - The Sandbox - GitBook
It is not possible to change the wallet that is connected to your account on The Sandbox. This is mainly due to technical...
Read more >
Solved: Cannot connect to DevNet sandbox (login failed)
Hi, i received login credentials for sa but i cannot connect using AnyConnect. devnet.PNG. This is how it looks when i try to...
Read more >
[devnet] Fetch using wrong URL · Issue #647 - GitHub
I have feeling this is the problem with the devnet sandbox, whenever it attempts a transaction or any fetch, it all always reverts...
Read more >
Sandbox Private Network - Algorand Developer Portal
Connect to sandbox using an SDK​​ To connect to the sandbox using an SDK, you can use the below connection object.
Read more >
Developer API (Sandbox) - Pipeline UI
$ ./sandbox up devnet -v. In order to test your Pipeline app, which uses MyAlgo Connect or WalletConnect to sign your transaction, your...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found