Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.


See original GitHub issue

Describe the bug I only want optimize PNG images. But the build crashes.

To Reproduce installed optipng set nuxt.config

optimizedImages: {
    handleImages: ['jpeg', 'png', 'svg', 'webp', 'gif'],
    optimizeImages: true,
    optipng: {
      optimizationLevel: 3,

then builld nuxt, it gives error on svg file somehow

ERROR in ./assets/img/some-image.svg 1:0 Module parse failed: Unexpected token (1:0) You may need an appropriate loader to handle this file type, currently no loaders are configured to process this file. See

<svg width="102" height="102" viewBox="0 0 102 102" fill="none" xmlns="">

my example images (Pug/Jade)



div(:style="'background-image: url(' + require('~/assets/img/test.jpg') + ')'")


Issue Analytics

  • State:open
  • Created 3 years ago
  • Comments:8 (1 by maintainers)

github_iconTop GitHub Comments

saint777commented, Mar 29, 2021

Nope its shitty plugin

сб, 27 мар. 2021 г., 19:10 ZS-Andisch @.***>:

Same problem. What have you done to fix it?

— You are receiving this because you were mentioned. Reply to this email directly, view it on GitHub, or unsubscribe .

juliomrqzcommented, Jan 2, 2021

@saint777 Can you provide a live example? Maybe using CodeSandbox. Thanks.

Read more comments on GitHub >

github_iconTop Results From Across the Web

FIX: Fatal error LNK1000 when you build a Visual C++ project ...
Fixes an issue in which you receive fatal error LNK1000 when you build a Visual C++ project in Visual Studio 2012 or in...
Read more >
Game Build Give Fatal Error - C++ - Unreal Engine Forums
Hello, I'm having a problem when I made a build using a plugin I made. When the Game is packaged and I run...
Read more >
Fatal error in building process - ROOT Forum
I downloaded the latest ROOT version via Terminal from Github. Steps 2-4 works fine. In Step 5 I get some fatal errors which...
Read more >
Solved: ISDEV : fatal error -6040: Internal build error
Hi all,. I've recently come across this error using Installshield 2015 when attempting to build installers that are supposed to support multiple languages....
Read more >
[IL2CPP] Build fails with "Fatal error in Unity CIL Linker" when ...
[IL2CPP] Build fails with "Fatal error in Unity CIL Linker" when using UnityLinker · 1. Open the user's attached “” project
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found