Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Can't get modules to run

See original GitHub issue


I’m on ubuntu and trying to get the example in to run but can’t. Just following the instructions i still get TypeError: Cannot read property 'fib' of undefined. I’m I missing somthing?

Or the http server example with the following:

make runtime
sudo make install
make MODULE=http module
sudo make -C modules/http install
make examples
cd examples/http
just server.js

same there TypeError: Cannot destructure property 'http' of 'just.library(...)' as it is undefined.

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Reactions:1
  • Comments:10 (4 by maintainers)

github_iconTop GitHub Comments

billywhizzcommented, Mar 5, 2021

hi @mattiasewers. i’ll take a look. should be pushing out a new release over weekend and will make sure examples are working. i’ll also be adding some automated tests and docs over coming weeks. thanks for your patience!

mtsewrscommented, Apr 1, 2021

@billywhizz works for me now, thanks!

Read more comments on GitHub >

github_iconTop Results From Across the Web

How do I resolve "Cannot find module" error using Node.js?
This solved an issue where Error: Cannot find module 'http-errors' randomly started showing when I tried to run my Express app.
Read more >
cannot find module [Node npm Error Solved] - freeCodeCamp
When you get the “cannot find module” error, or “module not found”, it means you've not installed the package you're trying to use....
Read more >
How to resolve can't find module error in Node.js - Reactgo
To fix Cannot find module errors, install the modules properly by running a npm install command in the appropriate directory as your project's ......
Read more >
Getting "Error: Cannot find module" when running basic setup ...
I am receiving the following error after setting up a basic setup with npm-run-all. npx npm-run-all echo Watching /private/tmp/npm-test and ...
Read more >
Why Can't Python Find My Modules? - Real Python
A common error that new Pythonistas will come across is that the packages they think they've installed are not actually being recognized by ......
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found