Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

no module named 'scapy' & requirements have not been satisfied properly.....

See original GitHub issue

Checklist for submitting an issue to KickThemOut:

  • [check] I have carefully read the README file and haven’t managed to resolve my issue.
  • [check] I have searched the issues of this repo and believe that this is not a duplicate.
  • [check] I am running the latest version of KickThemOut.
  • OS name & version: Linux version 4.15.0-kali2-amd64 ( (gcc version 7.3.0 (Debian 7.3.0-11)) #1 SMP Debian 4.15.11-1kali1 (2018-03-21)
  • Python version: 2.7.14 (i have also 10.6.0)
  • Scapy version: I don’t know yet
  • Nmap version: 7.70
  • Link of Gist:

  • Description: when I try: ‘Sudo python3’, kali linux says after it: 'ERROR: Requirements have not been satisfied properly. Please look at the README file for configuration instructions.

If you still cannot resolve this error, please submit an issue here:

Details: No module named ‘scapy’’

P.S.: ‘sudo apt-get install python3-pip and sudo -H pip3 install -r requirements.txt‘ also didn’t worked…

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Reactions:2
  • Comments:16 (3 by maintainers)

github_iconTop GitHub Comments

TeslaSSTeccommented, Jul 24, 2018

try to sudo apt-get install python3-pip and sudo -H pip3 install -r requirements.txt will be work

TeslaSSTeccommented, Jul 27, 2018

Sorry, I didn’t read that you tried. I use Parrot OS and can try write all commands from clean System to working script, if it’s interesting for you.

Read more comments on GitHub >

github_iconTop Results From Across the Web

ImportError: No module named scapy.all - Stack Overflow
After using "yum install scapy". The location is "/usr/lib/python3.6/site-packages/". If using pip3 or building python from source code, it ...
Read more >
ModuleNotFoundError: No module name scapy - Medium
After installing scapy, let's check out where it is installed. locate scapy. Mine is installed in home folder. The exact location is ~/.local/ ......
Read more >
How to install pip in Python 3 on Kali Linux (Fix ImportError No ...
This video will help you how to install and fix any problem of the pip or python 3 on Kali Linux.First Fix:cd /urs/lib/python2.7python ......
Read more >
cannot connect to https url because ssl module is not available
So the issue is caused by Anaconda Python ignoring the system SSL libraries and using its own. The only solution is to use...
Read more >
setuptools 3.7.1 - PyPI
ZipFile does not yet have support for context managers. ... Distribute no longer shadows setuptools if we require a 0.7-series setuptools. And an...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found