Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error while replicating example

See original GitHub issue

Hi, I tried to replicate one of the example that provided in this repo. In this case, I tried to replicate the Amazon one. I ran the code using param_amazon_linear like the one documented in that example, but all I got was this:

> java -Xmx3048m -jar StackNet.jar train train_file=train.sparse test_file=test.sparse params=param_amazon_linear.txt pred_file=amazon_linear_pred.csv test_target=false verbose=true Threads=1 sparse=true folds=5 seed=1 metric=auc
parameter name : train_file value :  train.sparse
parameter name : test_file value :  test.sparse
parameter name : params value :  param_amazon_linear.txt
parameter name : pred_file value :  amazon_linear_pred.csv
parameter name : test_target value :  false
parameter name : verbose value :  true
parameter name : threads value :  1
parameter name : sparse value :  true
parameter name : folds value :  5
parameter name : seed value :  1
parameter name : metric value :  auc
a train method needs to have a task which may be regression or classification

After I checked for awhile, it didn’t produce any output file. Is there something that I did wrong?

Additional note: I also already produced train.sparse and test.sparse by running

Issue Analytics

  • State:closed
  • Created 6 years ago
  • Comments:9 (2 by maintainers)

github_iconTop GitHub Comments

goldentom42commented, Aug 2, 2017

@Kaz-Anova, you’re welcome 😉 StackNet is a very powerful lib and reading your code is always a great source of inspiration. @arisbw, that’s right StackNet supports any coma separated text file as long as the first column is your target for the train file. if the test file does not contain a target then test_target argument should be set to false.

kaz-Anovacommented, Aug 2, 2017

I have added task=classification to the example. I have not updated StackNet for a while but I am working in the background to allow support for sklearn and keras models.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Troubleshoot common AD replication errors - Windows Server
Attempts to replicate Active Directory when schema information is not consistent between the domain controller partners that are involved result ...
Read more >
4.1.29 Replica Errors During Replication
If a statement produces different errors on the source and the replica, the replication SQL thread terminates, and the replica writes a message...
Read more >
Some replication architecture errors and their resolutions
In this article we are going to explain some replication architecture errors and their resolutions and caused by what is impossible and ...
Read more >
Error when replicating example · Issue #4 - GitHub
I've tried to replicate an example using your dataset arma_data.csv. ... Similar error when I replicate the random walk process example (in one...
Read more >
Basic replication error log - IBM
If the attribute does not exist in the replica entry or the attribute has no value, no errors are logged or replication operations...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found