Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error install keplergl jupyter widget in windows: Failed building wheel

See original GitHub issue

There seems to be an issue when I try to install keplergl-jupyter. I ran pip install keplergl-jupyter in the anaconda prompt and got the following error.


There was also a Failed building wheel for keplergl-jupyter error.

Please let me know the right way to download and use this module in Jupyter Notebooks. Thanks!

I am using the Windows OS.

Issue Analytics

  • State:open
  • Created 4 years ago
  • Comments:19 (3 by maintainers)

github_iconTop GitHub Comments

ricardoCyycommented, Jul 22, 2019

I followed @victorfgs 's advice and made it! But it took me 2 hours to figure out how to “manually” install these three packages. I hope the following notes would help some start-up programmers like me to save your time.

System: win10

Note 1: Install “manually” does not mean install the “.whl” files to your python library folder!

Note 2: Make sure you have “wheel” in pip lib. pip install wheel

Note 3: Verify the correct version of packages for your pip. Run following code in python to figure out which version of wheel to install: cpxx. Mine is “cp37”. AMD64: import pip._internal;print(pip._internal.pep425tags.get_supported()) win32: import pip; print(pip.pep425tags.get_supported())

Note 4: Go to sharpely/gdal/fiona to download “.whl” file, which supports your pip version. Mine are “{PackageName}‑3.0.1‑cp37‑cp37m‑win_amd64.whl”

Note 5: Get the absolute path of your “.whl” file (careful with ""). And run pip install path_of_whl_file

Note 6: After you successfully download above packages, you can easily install keplergl by running pip install keplergl

victorfgscommented, Jul 20, 2019

just had the same issue on Windows 10 here @GennyGeo solved by:

  • installing shapely manually;
  • installing gdal manually
  • installing fiona manually

hope you can make it work too 😉

Read more comments on GitHub >

github_iconTop Results From Across the Web

Jupyter Notebook -
keplergl is currently only published to PyPI, and unfortunately I use a Mac. If you encounter errors installing it on windows. This issue...
Read more >
Build Wheel Error when i installing JupyterLab - Stack Overflow
After downloading VS2017 build tools And Python 3.9, i try to install JupyterLab : Configuration. Operating System: Windows 10 Pro 64-bit ...
Read more >
04_Visualisation_KeplerGL - Databricks
#####Install Required Libs Here we are specifying a version for keplerGL. At the time of building these examples, the latest version did not...
Read more >
keplergl - PyPI
This is a simple jupyter widget for, an advanced geospatial visualization tool, to render large-scale interactive maps.
Read more >
Command errored out with exit status 1: python ...
When trying to install this I got the same error. ... C:\WINDOWS\system32>pip install keplergl Collecting keplergl Downloading keplergl-0.1.2.tar.gz (5.4 ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found