Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Build fails on Windows

See original GitHub issue

I’ve just purchased the Operator Mono SSm version for this project and when running “build” it fails

Compiling ".\build\OperatorMonoSSmLig-Book.ttx" to ".\build\OperatorMonoSSmLig-Book.otf"...
Parsing 'GlyphOrder' table...
Parsing 'head' table...
Parsing 'hhea' table...
Parsing 'maxp' table...
Parsing 'OS/2' table...
Parsing 'name' table...
Parsing 'cmap' table...
Parsing 'post' table...
Parsing 'CFF ' table...
Parsing 'GPOS' table...
Parsing 'GSUB' table...
Parsing 'hmtx' table...
Parsing 'DSIG' table...
ERROR: Unhandled exception has occurred
Traceback (most recent call last):
  File "c:\python27\lib\site-packages\fontTools\", line 399, in main
    process(jobs, options)
  File "c:\python27\lib\site-packages\fontTools\", line 373, in process
    action(input, output, options)
  File "c:\python27\lib\site-packages\fontTools\misc\", line 372, in wrapper
    return func(*args, **kwds)
  File "c:\python27\lib\site-packages\fontTools\", line 291, in ttCompile
  File "c:\python27\lib\site-packages\fontTools\ttLib\", line 172, in save
    writer_reordersTables = self._save(tmp)
  File "c:\python27\lib\site-packages\fontTools\ttLib\", line 211, in _save
    self._writeTable(tag, writer, done, tableCache)
  File "c:\python27\lib\site-packages\fontTools\ttLib\", line 624, in _writeTable
    self._writeTable(masterTable, writer, done, tableCache)
  File "c:\python27\lib\site-packages\fontTools\ttLib\", line 628, in _writeTable
    tabledata = self.getTableData(tag)
  File "c:\python27\lib\site-packages\fontTools\ttLib\", line 646, in getTableData
    return self.tables[tag].compile(self)
  File "c:\python27\lib\site-packages\fontTools\ttLib\tables\", line 20, in compile
    self.cff.compile(f, otFont, isCFF2=False)
  File "c:\python27\lib\site-packages\fontTools\cffLib\", line 108, in compile
  File "c:\python27\lib\site-packages\fontTools\cffLib\", line 2340, in recalcFontBBox
    bounds = charString.calcBounds(self.CharStrings)
  File "c:\python27\lib\site-packages\fontTools\misc\", line 984, in calcBounds
  File "c:\python27\lib\site-packages\fontTools\misc\", line 979, in draw
  File "c:\python27\lib\site-packages\fontTools\misc\", line 301, in execute
    rv = handler(index)
  File "c:\python27\lib\site-packages\fontTools\misc\", line 340, in op_callsubr
  File "c:\python27\lib\site-packages\fontTools\misc\", line 301, in execute
    rv = handler(index)
  File "c:\python27\lib\site-packages\fontTools\misc\", line 591, in op_rlineto
  File "c:\python27\lib\site-packages\fontTools\misc\", line 525, in rLineTo
  File "c:\python27\lib\site-packages\fontTools\misc\", line 514, in _nextPoint
    point = x + point[0], y + point[1]
IndexError: list index out of range

Similar errors appear for every single font-file and at the end, it’s all empty (0-bytes) otf-files in the build-folder.

Is there a specific version of the font-tools that it works best with? I’m not familiar with Python and currently at a loss.

Thanks for any help you guys can provide.

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Reactions:1
  • Comments:35 (12 by maintainers)

github_iconTop GitHub Comments

garyngcommented, May 27, 2018

I installed fonttools version 3.14.0 and it compiled successfully. image

The build was broken with fonttools on version >=3.15.0. Hope that helps.

edit: image the ligatures failed to render properly though… (IntelliJ IDEA)

COD3BREAK3Rcommented, Nov 4, 2020

Actually don’t work and i have tried with fonttools 3.14.0, why this issue is closed? this not as been solved

Read more comments on GitHub >

github_iconTop Results From Across the Web

build error on windows #3568 - google/mediapipe - GitHub
Describe the problem: When ran the follow command on windows, errors occured! I followed the official document. Can not find any solutions.
Read more >
Failed Builds - Visual Studio App Center - Microsoft Learn
A build can fail without any change in source code or build settings. For example: ... Try checking if the error for the...
Read more >
Docker Build Fails on Windows? - Stack Overflow
But on Windows 11 (PowerShell as administrator) I'm getting the following error: PS C:\> docker build -t ubuntu-docker:v1.0.2 ./ Get-Process : A ...
Read more >
Stop Killing Your FPS PC Build FAILS | Boost My Build S2:E15
Exploding PSU, Bad GPU, Wrong Motherboard, Not Enough Cooling - the list goes on! We fix the PC Build Fails and get you...
Read more >
HoloLens 2 build fails if Windows sdk is installed to any drive ...
Thank you for reporting this issue. We've created a new MSBuild issue to track this bug, see here: For now the ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found