Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

RM3 Mini D Code Sending Header Incorrect

See original GitHub issue

Hi there,

Looks like Device.code_sending_header is incorrect for RM3 Mini D 5f36. By default, the device is discovered but does not respond to learn or IR send commands. Previously, the modification here worked before today’s release, but I’m assuming that wasn’t supposed to happen since this isn’t an RM4 or RM4+ device, it’s RM3. So, the following change restores functionality for me in the new release:

this.code_sending_header = this.rm4Type ? new Buffer([0xda, 0x00]) : new Buffer([0xd0, 0x00]);

That’s probably incorrect for other tested devices, but in the case of RM3 Mini D it works starting the buffer with [0xd0, 0x00]. I have no other Broadlink devices to test with, but I’d be happy to make a PR for a conditional exception for this specific device (better than my band-aid above) if you think it’s a one-off for this model.

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:5 (3 by maintainers)

github_iconTop GitHub Comments

kiwi-camcommented, Dec 16, 2020

Thanks for testing so quickly. I’ll push a new release now - it sounds like it could help a few people in

blackadarcommented, Dec 16, 2020

Yes, that works out of the box now. Ran npm i kiwicam-broadlinkjs-rm@0.9.6-beta.0, and I verified this overwrote my change with yours.

Very odd exception, but maybe it’ll come up in newer firmware for RM3 devices? I ordered mine end of November from Amazon, found that other thread doing research as to why I couldn’t get it talking. Seems like an odd thing for them to just change.

If it helps to pin anything down here’s the device’s model info: IMG_7370

Thanks for looking into this so quick!

Read more comments on GitHub >

github_iconTop Results From Across the Web

Broadlink Mini 5f36 & IR Learn Code · Issue #551 - GitHub
The IR code learn does not work ... When you press the learn button in home app, the front led in rm Mini...
Read more >
Reverse-engineering Broadlink RM Pro+ devices - Hardware
Hi everyone, I've just bought a Broadlink RM3 (the newest version at the time of ... Send RM_SERV_CHECK Send IP 38f7720d port 16384....
Read more >
Use the new Broadlink integration by @tomw] NATIVE ...
Hello all,. I am using v0.50 with a just purchased off amazon BroadLink RM mini 3. I was able to get things working,...
Read more >
Keri Systems Help Center | Home
Technical documentation and resources for all Keri products ... Mercury Hardware documentation: Application Notes, how-to-guides, data sheets, quick start, setup ...
Read more >
Trouble getting Broadlink RM4 Pro to consistently work - Reddit
Tried with RM3 and RM4 pro with RF codes. If anyone knows what causes this let me know too!
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found