Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Crash with (0xc0000005) 'Access violation' exception.

See original GitHub issue

I am trying to assemble many tiles to create a new image. for this, i have make this :

  await Task.Run(() =>
                var image = NetVips.Image.Black(18642 + 1, 10860 + 1);
                string save_directory = @"C:\Users\franc\Documents\SharpDevelop Projects\Test_Netvips\Test_Netvips\images\";
                for (int decalage_boucle_for_y = 0; decalage_boucle_for_y <= 42; decalage_boucle_for_y++)
                    for (int decalage_boucle_for_x = 0; decalage_boucle_for_x <= 73; decalage_boucle_for_x++)
                        int tuile_x = 135732 + decalage_boucle_for_x;
                        int tuile_y = 90908 + decalage_boucle_for_y;

                        int pixel_decalage_x = (decalage_boucle_for_x * 256);
                        int pixel_decalage_y = (decalage_boucle_for_y * 256);

                        string filename = save_directory + "tiles\\" + tuile_y + "_" + tuile_x + "." + "jpeg"; ;
                        using var tile = NetVips.Image.NewFromFile(filename);
                        image = image.Insert(tile, pixel_decalage_x, pixel_decalage_y);

                image.WriteToFile(save_directory + "final.jpeg");
                image = null;

When i run this code, all working perfectly but sometimes, after few secondes, the exe close and print into the console this :

Le programme '[20928] Test_Netvips.exe' s'est arrêté avec le code -1073741819 (0xc0000005) 'Access violation'.

here, a full exemple app where i have the issue : and here a .zip with all of my tiles for my exemple app (39MO) :

What is wrong ? Ps : Sorry for my bad english :p

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:8 (4 by maintainers)

github_iconTop GitHub Comments

SioGabxcommented, Oct 22, 2021

That’s good. I would check arrayjoin as well – it should be quite a bit quicker.

Effectively, arrayjoin for the same work save me 2Go of ram and is a lot faster 😄

jcupittcommented, Oct 22, 2021

That’s good. I would check arrayjoin as well – it should be quite a bit quicker.

Read more comments on GitHub >

github_iconTop Results From Across the Web

You receive a "0xc0000005 Access violation" error message
Symptoms. When you try to back up a folder that has quotas enabled on it, you may receive a 0xc0000005 access violation error...
Read more >
What exactly is the scope of Access Violation '0xc0000005'?
I'm not sure of the specifics, but an AV just means that: the processor tried to read from or write to a particular...
Read more >
How to fix Access Violation error 0xC0000005 on Windows?
It is stated that 0xC0000005 error usually occurs when a particular application is trying to access memory, which is no longer available or ......
Read more >
0xC0000005 Access Violation - How to Repair It
This 0xc0000005 access violation error is often the result of poor system maintenance and a corrupted operating system registry. Corruption in the registry...
Read more >
What is error 0xc0000005 Access Violation?
It's triggered by system issues that prevent Windows from accessing the files and settings required for launching one or more applications. Takedown request ......
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found