Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Titanic Example: loaddata fails

See original GitHub issue


I’m trying to compile/execute the official titanic-ml example, but I have the issue that the python packages which I import under the tag “imports” cannot be found when I run the pipeline. For example, in the step loaddata, I get

ModuleNotFoundError: No module named 'seaborn'

So does that mean that kale does not take care of making sure that all imported packages are actually installed and that I have to do it myself by either

  • using subprocess inside my code
  • referring to a docker image that has the package preinstalled? In this case, what if my docker image is in a private repository, do I then need to manually edit the generated script and add image pull secrets?

(I also noticed that in the Kale panel, the option “Use this notebook’s volumes” is disabled and I cannot enable it on the UI. Could these issues be related to one another?)

Would be very grateful for some advice! I’m using Kubeflow 0.7 and my notebook server is based on the image The kubeflow-kale version is 0.3.4. If you need any additional info, I’d be happy to provide them.

Issue Analytics

  • State:open
  • Created 4 years ago
  • Comments:9 (3 by maintainers)

github_iconTop GitHub Comments

OnTheRickycommented, Apr 20, 2020

Does this also mean I need to compile my image to contain the data, or is there a way to point to the data?

oncebasuncommented, Apr 7, 2020

Hi @StefanoFioravanzo,

I got the same issue. Is there a solution without MiniKF? I am using a shared kubeflow cluster and I am not the admin, so I can not switch to MiniKF. Thank you!

Read more comments on GitHub >

github_iconTop Results From Across the Web

Titanic Example Freezes on Load Data #65 - GitHub
When I run the titanic-ML example, it freezes on the loaddata stage. I suspect the problem is that my kale environment doesn't allow...
Read more >
4.1 Load Data | Do A Data Science Project in 10 Days
Here are a simple plan for understand the Titanic data: Get Titanic data load into RStudio; Assess Data quantity (number of files, size...
Read more >
Titanic workshop data import - identifiers table - Beginner Support ...
Hi DataSHIELD users, when trying to import the sample data set used in the “Titanic newcomers workshop” I still run into a problem...
Read more >
Titanic - Machine Learning from Disaster | Kaggle
Titanic - Machine Learning from Disaster ... Predict survival on the Titanic and get familiar with ML basics ... Could not load data:...
Read more >
Your Guide for Logistic Regression with Titanic Dataset
Maximum Likelihood Estimation involves treating the problem as an ... in the best fit for the joint probability of the data sample (X)....
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found