Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Startup error in get_linux_directories

See original GitHub issue

When starting LBRY-0.33.2 the first time on Ubuntu 19.04, I get the following message during startup:

The daemon may have encountered an unexpected error, or another daemon instance is already running.

The log file does not exist, but the console has the following output:

Starting SDK
Sandbox listening on port 5278.
Daemon: [17050] Failed to execute script cli

Daemon: Traceback (most recent call last):
  File "lbrynet/extras/", line 322, in <module>
  File "lbrynet/extras/", line 229, in main
  File "lbrynet/", line 400, in create_from_arguments
  File "lbrynet/", line 570, in __init__
  File "lbrynet/", line 582, in set_default_paths
  File "lbrynet/", line 621, in get_linux_directories
AttributeError: 'NoneType' object has no attribute 'group'

I tried manually creating the ~/.config/LBRY/user-dirs.dirs according to the code that tries to read it, but the exception is still the same.

I’m running Python 3.7.3, which has FileNotFoundError inherit from OSError instead of EnvironmentError, but this was apparently changed in 3.3 so already a long time ago. Does LBRY bundle it’s own python interpreter?

Issue Analytics

  • State:open
  • Created 4 years ago
  • Comments:5 (3 by maintainers)

github_iconTop GitHub Comments

shausercommented, Sep 23, 2019

Sorry, I was busy with other stuff in the last few months. I just checked back with this issue…

The error actually occurs when the file ~/.config/user-dirs.dirs exists, but is empty. I don’t know why this happened though, but after removing the file or recreating it with xdg-user-dirs-update lbrynet works flawlessly.

tzarebczancommented, Sep 23, 2019

Thanks for the feedback! Can we show you some appreciation for the info ?

@eukreign should we try to handle this scenario or mark this closed as a environment specific issue. I haven’t seen it happen elsewhere.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Issues on startup due to error messages about directory #2189
This bug was a regression of a huge change in filesystem handling. It is already fixed on master, but the ubuntu package seems...
Read more >
fatal: Unable to read current working directory: No such file or ...
Whenever git is run with the GIT_DIR environment variable set, and GIT_WORK_TREE not set, it presumes that '.' is the working tree. So......
Read more >
Git error - Fatal: Not a git repository and how to fix it |
This error means you attempted to run a Git command, but weren't inside a Git repository. Make sure you've: Navigated to the right...
Read more >
Solving “Fatal: Not A Git Repository” (Or Any Of The Parent ...
In this article, we will explore what causes, how to prevent, and how to solve the “fatal: not a git repository” error.
Read more >
fatal: not a git repository (or any of the parent ... - Initial Commit
In this article, we'll discuss the reasons for the error `fatal: not a git repository (or any of the parent directories): .git` and...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found