Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

working with

See original GitHub issue


First of all, thanks a lot for sharing what seems to be such an interactive python library for data visualisation. I just discovered vtkplotter and try to use this to visualise my results more meaningfully. However, I think I’ve got a quick naive question.

When I tried to load a .obj mesh and visualise it using, it doesn’t launch the visual graphic. Instead it give something like following, which according to my idea contains some meta data of the visual.

`In [6]: show(m)

Out[6]: Plot(antialias=3, axes=[‘x’, ‘y’, ‘z’], axes_helper=1.0, background_color=16777215, camera=[0.012851721776526668, 0.01323173118929217, 0.6199803058828682, 0.0036249905824661255, 0.004004999995231628, 0.004834994673728943, 0, 1, 0], camera_auto_fit=False, camera_fov=60.0, fps=25.0, fps_meter=False, grid=[-0.2778100073337555, -0.263729989528656, -0.24404999613761902, 0.28505998849868774, 0.27173998951911926, 0.2537199854850769], height=500, lighting=1.2, mode=‘view’, object_ids=[112670800472], screenshot_scale=2.0)`

Any idea what I’m missing here ?

Thank you in advance for your time.

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:6 (3 by maintainers)

github_iconTop GitHub Comments

ifermioncommented, Jan 30, 2020

Now I think the issue is related to ipython. I’m still not able to make it run inside ipython. But it works just fine when called from the terminal without launching the ipython console. Thanks anyway for your help in trying to isolate the issue.

marcomusycommented, Jan 22, 2020

Uhm… that’s pretty weird… This happens in jupyterlab not on jupyter notebook. From Out[5] I see you are using the K3D backend. Other options are embedWindow('itk') embedWindow('panel') embedWindow('2d') embedWindow(False) I’ll give it a try on my macbook too.

Read more comments on GitHub >

github_iconTop Results From Across the Web

working with · Issue #97 · marcomusy/vedo
When I tried to load a .obj mesh and visualise it using, it doesn't launch the visual graphic. Instead it give something ......
Read more >
How to interact with vtkplotter using custom functions?
You need to render the scene in the loop. I would try something easier like: import time from vedo import * a =...
Read more >
vedo.plotter API documentation
Create on the fly an instance of class Plotter and show the object(s) provided. Allowed input objects types are: str, Mesh, Volume, Picture, ......
Read more >
VTK - The Visualization Toolkit
The Visualization Toolkit (VTK) is open source software for manipulating and displaying scientific data. It comes with state-of-the-art tools for 3D rendering, ...
Read more >
Plotting : no windows shows up - FEniCS Project
Hi all, I'm trying to show plots with matplotlib. ... Plotting : no windows shows up ... u, bc) plot(u) plt.savefig('u.png').
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found