question-mark
Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

OpenVPN interfaces doesn't show ip addresses

See original GitHub issue

In the Interfaces page all the interfaces tied to tun/tap devices doesn’t show any ip address. This was not the case with CC 15.05.

lede trunk openwrt cc 15 05 archer c7

As you can see in the first image there is nothing, instead in the second there are ip (the second is CC 15.05).

My /etc/config/network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'XXXX:XXXX:XXXX::/48'

config interface 'lan'
	option force_link '1'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option igmp_snooping '0'
	option metric '0'
	option stp '1'
	option ipaddr '192.168.0.1'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr 'XX:XX:XX:XX:XX:XX'

config interface 'wan'
	option ifname 'eth0.2'
	option _orig_ifname 'eth0.2'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option username 'XXX'
	option password 'XXX'
	option ipv6 'auto'
	option metric '1'
	option peerdns '0'
	option dns '127.0.0.1'
	option keepalive '20 4'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr 'XX:XX:XX:XX:XX:XX'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'

config interface 'bridgetcp'
	option proto 'none'
	option auto '1'
	option ifname 'tun1'
	option igmp_snooping '0'

config interface 'vpn'
	option _orig_ifname 'tun2'
	option _orig_bridge 'false'
	option ifname 'tun2'
	option proto 'none'
	option auto '1'
	option delegate '0'
	option defaultroute '1'
	option metric '100'

config interface 'P2P'
	option proto 'none'
	option ifname 'tun3'
	option auto '1'
	option delegate '0'
	option defaultroute '1'
	option metric '90'

config interface 'bridgeudp'
	option ifname 'tun-br-vpnudp'
	option proto 'none'
	option auto '1'
	option igmp_snooping '0'

config interface 'setup'
	option proto 'static'
	option delegate '0'
	option ipaddr '192.168.254.1'
	option netmask '255.255.255.0'

Issue Analytics

  • State:closed
  • Created 7 years ago
  • Comments:8 (3 by maintainers)

github_iconTop GitHub Comments

1reaction
bol-vancommented, Dec 10, 2016

I can share my work but I dont pretend it to be the best quality and decisions made were perfect. I done it for myself.

0reactions
geekysagarjaincommented, Feb 9, 2022

@bol-van Please share your code again your given link has been expired.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Troubleshooting Access To The Web Interface | OpenVPN
If the IP addresses from the initial configuration don't work, check the IP address of the instance of the cloud provider. For installations...
Read more >
Openvpn interface not getting ip? : r/PFSENSE - Reddit
I believe openvpn doesn't create an interface by default. If you go to interfaces -> assignments, it should be available to be added...
Read more >
Troubleshooting OpenVPN | pfSense Documentation
On This Page · Check OpenVPN Status · Check Firewall Log · Some hosts work, but not all · Check the OpenVPN logs...
Read more >
Connects to the VPN, but doesn't work - Tunnelblick
If OpenVPN connects to the server properly but your IP address does not change, your OpenVPN setup needs to include the "--redirect-gateway" ...
Read more >
Help A Newb Configure OpenVPN for VPN Service
That would explain why the routing rule did not work. Try the interface-route again with the correct ip address for whatismyipaddress.com.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Dev.to Post

No results found

github_iconTop Related Hashnode Post

No results found