Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Pipenv install fails to install sub dependencies from private repos

See original GitHub issue
Describe you environment
  1. OSX (MAC)
  2. Python version: 2.7.10
  3. Pipenv version: 8.2.6


  1. inside invocations repo -> installing CaaS package :

  1. Installing invocations in a virtualenv python install

  2. Valdiating CaaS installed correctly.

(test_1) c4b301cf5d25:invocations quj291$ pip freeze

So far everything works.

  1. Created a Pipfile
python_version = '2.7'

invocations = { git = 'git://<private-repo>/invocations',  ref = 'master' }
  1. Fails to install invocations because CaaS package cannot be found: pipenv install
Collecting CaaS>=1.0 (from invocations)

  Could not find a version that satisfies the requirement CaaS>=1.0 (from invocations) (from versions: )
No matching distribution found for CaaS>=1.0 (from invocations)
  1. Tried pipenv install --verbose
Collecting CaaS>=1.0 (from invocations)
  1 location(s) to search for versions of CaaS:
  Getting page
  Looking up "" in the cache
  No cache entry available
  Starting new HTTPS connection (1):
  "GET /simple/caas/ HTTP/1.1" 404 33
  Status code 404 not in [200, 203, 300, 301]
  Could not fetch URL 404 Client Error: Not Found (caas does not exist) for url: - skipping
Cleaning up...

Tries to get CaaS from pypi instead of private github repo’s inside dependency_links of invocation’s

Is this expected? How can I install CaaS package?


Issue Analytics

  • State:closed
  • Created 6 years ago
  • Reactions:2
  • Comments:18 (11 by maintainers)

github_iconTop GitHub Comments

kennethreitzcommented, Nov 22, 2017

known, designed this way

techalchemycommented, Dec 2, 2017

@manihamidi I believe you can set the environment variable PIP_PROCESS_DEPENDENCY_LINKS=1 or something like that to have pip recognize this if you need it, can you see if that helps?

Also thanks for the super-detailed info, makes it really clear what you’re trying to do and why its not working!

Read more comments on GitHub >

github_iconTop Results From Across the Web

Pipenv - Short way to install libs from private repos
Using pipenv I'd like to install from private repo. My Pipfile contents: ... You likely have a mismatch in your sub-dependencies.
Read more >
Advanced Usage of Pipenv - Read the Docs
Dependencies of wheels provided in a Pipfile will not be captured by $ pipenv lock . There are some known issues with using...
Read more >
pipenv Documentation - Read the Docs
Will create a virtual env and install dependencies (if it does not exist already) The dependencies will be installed inside. • install package==0.2...
Read more >
Error with pip install from PyPI in self hosted Gitlab - General
UPDATE: I tried installing all dependencies first and then installing the library which does work. But yeah this kinds of defeats the point...
Read more >
Snyk for Python - Snyk User Docs
To build the dependency tree, run pipenv install as Snyk needs this to create the pipenv graph which is then used for the...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found