Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

pipenv shell --fancy doesn't see any of the packages installed

See original GitHub issue

If I run pipenv shell --fancy then when I run my script it complains that none of the packages installed with pipenv install are available.

IfI run just pipenv shell it works and packages are recognized and script works but it messes up the shell (oh-my-zsh/prezto/fish).

pipenv, version 2018.10.13

Python 3.7.2

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:5 (1 by maintainers)

github_iconTop GitHub Comments

dltacubecommented, Feb 11, 2019

I’m running into the same issue. It seems like the answer to our issue is discussed here however, I haven’t been able to fix it.

The way I’m interpreting those instructions, is that I need to go into my shell config file and wrap everything in an if status --is-login block. Tried that but it doesn’t resolve the issue but can confirm that nothing in the if block runs when using pipenv shell --fancy.

The only difference between using fancy and not using it is the source ... line appears in the latter. Other than that, I’m stuck. Sorry, wish I could be more helpful.

PS: Beware, changes you make when --fancy fails to enter your virtual environment can affect your system-wide packages. I learned that the hard way.

dltacubecommented, Mar 21, 2019

Hey @techalchemy, no need to reopen the issue or anything but I ran --support and just thought I’d post it here in case you see anything obvious. My workaround at the moment is not to use the --fancy option and to avoid having the repo name show up twice, I set theme_display_virtualenv to no, so that’s been working well enough for me so far 😃

 ~  pipenv --support                                                                                          Thu Mar 21 10:26:05 2019
<details><summary>$ pipenv --support</summary>

Pipenv version: `'2018.11.26'`

Pipenv location: `'/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/pipenv'`

Python location: `'/Library/Frameworks/Python.framework/Versions/3.7/bin/python3.7'`

Python installations found:

  - `3.7.1`: `/Library/Frameworks/Python.framework/Versions/3.7/bin/python3`
  - `3.7.1`: `/Library/Frameworks/Python.framework/Versions/3.7/bin/python3.7m`
  - `2.7.15`: `/Library/Frameworks/Python.framework/Versions/2.7/bin/python`
  - `2.7.15`: `/Library/Frameworks/Python.framework/Versions/2.7/bin/pythonw`
  - `2.7.10`: `/usr/bin/python`
  - `2.7.10`: `/usr/bin/pythonw`
  - `2.7.10`: `/usr/bin/python2.7`

PEP 508 Information:

{'implementation_name': 'cpython',
 'implementation_version': '3.7.1',
 'os_name': 'posix',
 'platform_machine': 'x86_64',
 'platform_python_implementation': 'CPython',
 'platform_release': '18.2.0',
 'platform_system': 'Darwin',
 'platform_version': 'Darwin Kernel Version 18.2.0: Thu Dec 20 20:46:53 PST '
                     '2018; root:xnu-4903.241.1~1/RELEASE_X86_64',
 'python_full_version': '3.7.1',
 'python_version': '3.7',
 'sys_platform': 'darwin'}

System environment variables:

  - `Apple_PubSub_Socket_Render`
  - `GOPATH`
  - `HOME`
  - `LANG`
  - `OMF_PATH`
  - `PATH`
  - `PWD`
  - `SHELL`
  - `SHLVL`
  - `TERM`
  - `TMPDIR`
  - `USER`
  - `fish_prompt_pwd_dir_length`
  - `theme_display_virtualenv`

Pipenv–specific environment variables:

Debug–specific environment variables:

  - `PATH`: `/usr/local/opt/ruby/bin:/usr/local/lib/ruby/gems/2.6.0/bin:/usr/local/java_home:/usr/local/opt/gnu-sed/libexec/gnubin:/usr/local/opt/grep/libexec/gnubin:/Users/jrevah/Library/Python/3.7/bin:/Library/Frameworks/Python.framework/Versions/3.7/bin:/usr/local/opt/freetds@0.91/bin:/Library/Frameworks/Python.framework/Versions/2.7/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Users/jrevah/go/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/share/dotnet:~/.dotnet/tools:/Library/Frameworks/Mono.framework/Versions/Current/Commands:/Applications/`
  - `SHELL`: `/usr/local/bin/fish`
  - `LANG`: `en_US.UTF-8`
  - `PWD`: `/Users/jrevah`


Read more comments on GitHub >

github_iconTop Results From Across the Web

Frequently Encountered Pipenv Problems - Read the Docs
This is usually a result of mixing Pipenv with system packages. We strongly recommend installing Pipenv in an isolated environment. Uninstall all existing ......
Read more >
How can I see the current version of packages installed by ...
1.go in project folder. 2.first activate pipenv type pipenv shell . 3.type pip freeze.
Read more >
pipenv Documentation - Read the Docs
Pipenv is a tool that aims to bring the best of all packaging worlds (bundler, composer, npm, cargo, yarn, etc.) to the. Python...
Read more >
Advanced Usage of Pipenv - Python Packaging Authority
Pipenv allows you to open any Python module that is installed (including ones in your codebase), with the $ pipenv open command: $...
Read more >
Advanced Usage of Pipenv — pipenv 7.7.9 documentation
$ pipenv install¶ · --dev — Install both develop and default packages from Pipfile.lock . · --system — Use the system pip command...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found