Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

UNC paths are not supported. Defaulting to Windows directory.

See original GitHub issue

Running pipenv shell from (Administrator) command prompt in Windows 10 Pro to launch virtual environment outputs:

UNC paths are not supported. Defaulting to Windows directory.

when run from within a mapped network drive.

The virtual environment does not show up in () before the drive. (If I am in the virtual environment at this point, it is easy to forget that I am and I could forget to exit out. Moreover, it doesn’t show which environment I’m in).

If I type activate afterwards, the environment in () shows up, but I don’t have to be in the folder where Pipfile or Pipfile.lock are located.

  1. Is this expected behavior?
  2. Is this somehow a holdover from virtualenv’s or virtualenvwrapper’s ability to utilize UNC paths?

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:31 (12 by maintainers)

github_iconTop GitHub Comments

ghostcommented, Jun 16, 2018

Hello @techalchemy and @erinxocon. I can confirm on my machine that PR #2331 has solved the issue of this PR! (Must clone repo into site-packages and install with pip install -e . as not yet available from current pipenv wheel using pip install pipenv.) Thank you so much for your help.

As an aside, I’m getting a few new interesting errors when trying to install packages now. This is a separate issue though. I’ll post on StackOverflow to see if I can get any resolution on it, but here is the text file for your records.


Thank you again so much and have a great weekend!

ghostcommented, Jun 10, 2018

@techalchemy Can we start over? I feel we got off on the wrong foot and I’m sorry. I was frustrated.

I respect your authority as the maintainer and completely understand its importance and necessity. I’m sorry if I came across as though I had the right to contribute. I do not. I apologize.

Read more comments on GitHub >

github_iconTop Results From Across the Web

UNC paths are not supported. Error Message comes up. Is it ...
"CMD. EXE was started with the above path as the current directory. UNC paths are not supported. Defaulting to Window directory."
Read more >
UNC Paths Not Supported - Windows and Daylighting
UNC Paths Not Supported ... If you open a file with such a path, the program will crash when you try to import...
Read more >
How to run batch file from network share without "UNC path ...
I am trying to run a batch file from a network share, but I keep getting the following message: "UNC path are not...
Read more >
CMD does not support UNC paths as current directories | Fix ...
Solved - Trying to access a share drive from the command prompt on your Windows 10 computer. This Video give you a details...
Read more >
"UNC paths are not supported. Defaulting to Windows ...
"UNC paths are not supported. Defaulting to Windows directory." when launching Autodesk Online Deployment .bat file.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found