Rename `parameter_values` to `parameter_vectors` in primitives
See original GitHub issueWhat should we add?
I have been bothered lately by the fact the we call parameter_values
to a Sequence[Sequence[float]]
in the primitives, and I think it is leading to confusion.
I keep coming across with loops like:
for parameter_value in parameter_values:
...
which seems intuitive but it is semantically wrong, because the type of parameter_value
here is Sequence[float]
.
I wanted to propose renaming ~paramenter_values
~ to parameter_bindings
. This will make everything more clear imho:
for binding in parameter_bindings:
for value in binding:
...
Issue Analytics
- State:
- Created a year ago
- Comments:13 (13 by maintainers)
Top Results From Across the Web
8.3 Parameters, priors, and prior predictions
We want to know how likely a given logically possible data observation Dpred D pred is, according to the model with its a...
Read more >Abstract
The commenter asks for all TX/RXVECTOR parameters. ... uniquely, L_LENGTH and L_DATARATE are remapped (renamed) within clause 36 to LENGTH ...
Read more >Release Notes
Qiskit Metapackage Version qiskit‑terra qiskit‑aer qiskit‑ibmq‑provider Release Date
0.39.4 0.22.3 0.11.2 0.19.2 2022‑12‑08
0.39.3 0.22.3 0.11.1 0.19.2 2022‑11‑25
0.39.2 0.22.2 0.11.1 0.19.2 2022‑11‑03
Read more >Positivity preserving and entropy consistent approximate ...
Then, we describe how to monitor these parameters to ensure good ... on primitive variables supplemented with classical van Leer slope ...
Read more >A Astrophysical Constants and Symbols - Springer Link
ables U and primitive variables P. The time integration of GRMHD determines the ... parameters have been measured for the millisecond pulsar PSR...
Read more >Top Related Medium Post
No results found
Top Related StackOverflow Question
No results found
Troubleshoot Live Code
Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start FreeTop Related Reddit Thread
No results found
Top Related Hackernoon Post
No results found
Top Related Tweet
No results found
Top Related Dev.to Post
No results found
Top Related Hashnode Post
No results found
Top GitHub Comments
transpile
’s argument iscircuits
. We used it for consistency.The
ParameterVector
nicely solves some problems we had with parameterized ansätze, like sorting by index if the name is the same (to sorta b[0] b[1] b[2] ... z
instead ofa b[0] b[1] b[10] .... z
) and adjusting the number of parameters if the ansatz is resized (which e.g.TwoLocal
circuits allow) 😄 I see howparameter_vectors
is confusing as name, maybe we need to choose something else in that case 🤔